Напишите программу которая получает с клавиатуры 2 целых числа и вычисляет их произведение, используя только операции сложения. пробить через repeat(постусловие
Readln(a,b); mu:=0; Repeat mu:=mu+a; Dec(b); Until b=0; Writeln(mu);
tatyana58
10.12.2021
#include <iostream> using namespace std; int main() { setlocale (0,""); int n1,n2,n3,p1,p2,p3; cout<<"введите количество учеников в каждом классе"<<endl; cout<<"1-"; cin>>n1; cout<<"2-"; cin>>n2; cout<<"3-"; cin>>n3; p1=n1/2; if (n1%2!=0) p1++; p2=n2/2; if (n2%2!=0) p2++; p3=n3/2; if (n3%2!=0) p3++; cout<<"для первого класса - "<<p1<<endl; cout<<"для второго класса - "<<p2<<endl; cout<<"для третьего класса - "<<p3<<endl; return 0; }
Dmitrii_Shamilevich2019
10.12.2021
Const n=8; var x : array[1..n] of real; i : integer; min : real; begin Randomize; writeln('Исходный массив:'); for i:=1 to n do begin x[i]:=20*random-10; write(x[i]:6:2,' '); end; writeln; min:=x[1]; for i:=2 to n do if x[i] < min then min:=x[i]; writeln('min=',min:6:2); for i:=1 to n do if x[i]<0 then x[i]:=min; writeln('Измененный массив:'); for i:=1 to n do write(x[i]:6:2,' '); end.
mu:=0;
Repeat
mu:=mu+a;
Dec(b);
Until b=0;
Writeln(mu);