Boyaris
?>

Написать программу которая решает уравнение ax^2+bx+c=0 . если d< 0 то решений нет , если d=0 то 1 корень. еси d > 0 - 2 корня

Информатика

Ответы

AlekseiMardanova
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3('введите a, b и c через пробел');
var D:=b*b-4*a*c;
if D>0 then write('два различных корня: x1=',(-b+sqrt(D))/(2*a),'; x2=',(-b-sqrt(D))/(2*a)) else if D=0 then
write('два совпадающих корня: x1=x2=',-b/(2*a)) else
write('нет действительных корней');
end.
Kotvitskii

Paint — специальная достаточно функциональная утилита для рисования и редактирования фотографий, узнать о ней подробнее, вы можете в статье о том, как пользоваться paint;

Wordpad и Блокнот — служат для печати, по сути они оба одинаковые, различие лишь в том, что wordpad функциональнее;

Выполнить — это аналог поиска в меню пуск;

Записки — это заметки, которые вы можете добавить на рабочий стол, чтобы не забыть о чём-либо;

Звукозапись записи звука с микрофона, но перед тем, как начать запись, нужно подключить микрофон и установить драйвера для него;

Калькулятор — это достаточно функциональный калькулятор, служащий для всяческих вычислений;

Командная строка — специальная утилита для указания разных команд компьютеру. Например, здесь вы можете сделать загрузочную флешку;

Подключение к удалённому рабочему столу — нужна для того, чтобы на расстоянии подключиться к компьютеру с сети интернет;

Проводник — Это программа для навигации между папками и файлами, открыть его можно двумя здесь и нажатием на ярлык «мой компьютер».

zuzman601
#include <iostream> #include <vector> #include <algorithm> #include <numeric> int main() { std::vector<int> arrayOfDummies; for (char answer{0};;) {  std::cout << "You want to enter a rating?" << std::endl;  std::cin >> answer;  if (int value{0}; answer == 'y')  {   std::cout << "Enter rating:";   std::cin >> value;   arrayOfDummies.push_back(value);  }  else break; } std::cout << "Average: " << std::accumulate(arrayOfDummies.begin(), arrayOfDummies.end(), 0) /    arrayOfDummies.size() << std::endl; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая решает уравнение ax^2+bx+c=0 . если d< 0 то решений нет , если d=0 то 1 корень. еси d > 0 - 2 корня
Ваше имя (никнейм)*
Email*
Комментарий*