sklad
?>

Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Информатика

Ответы

Tatarnikova1507
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadArrInteger(ReadInteger()).Where(x->x mod 8=0);
write('кол-во чисел, делящихся на 8 без остатка: ',a.Count(),'; сумма: ',a.Sum());
end.
Mikhailova
Program qq;
var a, b, c, d, e:integer;
BEGIN
d:=0;
e:=0;
writeln('Введите количество чисел');
readln (a);
writeln ('Введите числа');
for b:=1 to a do
begin

readln (c);
if c mod 8 = 0 then
d:=d+c;
e:=e+1;
end;
Writeln ('Количество чисел кратных восьми - ', e, '; Их сумма - ', d);
END.
whitecatrussia5398

х=7690 - условие

var x, L, M: integer;

begin readln(x);

L:=0;

M:=0;

while x > 0 do begin

1) L:= L + 1 = 1;

M:= M + x mod 10 = 0;

x:= x div 10 = 7 69;

2) L:= L + 1 = 2;

M:= M + x mod 10 = 9;

x:= x div 10 = 7 6;

3) L:= L + 1 = 3;

M:= M + x mod 10 = 15;

x:= x div 10 = 7 ;

4) L:= L + 1 = 4;

M:= M + x mod 10 = 22;

x:= x div 10 = 0;

end;

writeln(L);

write(M);

end.

L = 4; M = 22

Объяснение:

1)L:= L + 1 = 0 + 1 = 1;

M:= M + x mod 10 = 0 + 0 (остаток) = 0;

x:= x div 10 = 7690 : 10 = 769 (остаток 0 здесь не пишется);

2)L:= L + 1 = 1 + 1 = 2;

M:= M + x mod 10 = 0 + 9 (остаток) = 9;

x:= x div 10 = 769 : 10 = 76 (остаток 9 здесь не пишется);

3)L:= L + 1 = 2 + 1 = 3;

M:= M + x mod 10 = 9 + 6 (остаток) = 15;

x:= x div 10 = 76 : 10 = 7 (остаток 6 здесь не пишется);

4)L:= L + 1 = 3 + 1 = 4;

M:= M + x mod 10 = 15 + 7 (остаток) = 22;

x:= x div 10 = 7 : 10 = 0 (остаток 7 здесь не пишется);

galichka12
Var
 x,a,b,c,max,min,mid:real;
begin
 readln(x);
 a:=sin(x);
 b:=cos(x);
 if a>0 then
  begin
   c:=ln(x);
   if (a>b) and (a>c) then max:=a else
   if (b>a) and (b>c) then max:=b else max:=c;
   if (a<b) and (a<c) then min:=a else
   if (b<a) and (b<c) then min:=b else min:=c;
   if (a>min) and (a<max) then mid:=a else
    if (b>min) and (b<max) then mid:=b else mid:=c;
   writeln(min,' ',mid,' ',max);
  end
 else
  if a>b then writeln(b,' ',a) else writeln(a,' ',b);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bolshakova Shigorina
NurlanAleksandrovich
Antonov-Elena
YeVgenii
evoque2014
snabomp
rusinfopro
Надежда-Алексеевна82
Чщму доривнюе выраз 17 div 3
Valentina
SAMSCHOOL96
swetlanafatinia7323
Ainura Pokhomova
hamelleon43
emmakazaryan290
Verakravez8790
▲