Zhamynchiev
?>

Составить программу 7 класс: автомобиль проезжает первую часть пути длиной в s1 км за t1 мин, участок пути длиной s2 км за t2 мин, и участок пути s3 км за t3 мин. найдите среднюю скорость автомобиля в км\ч.

Информатика

Ответы

denis302007
Var
s,t,s1,t1:real;
begin
Writeln('Введите s1 и t1');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
Writeln('Введите s2 и t2');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
Writeln('Введите s3 и t3');
Readln(s1,t1);
s:= s +s1; t:= t + t1;
t:= t / 60;
Writeln(s/t)
end.

Пример:
Введите s1 и t1
15 10
Введите s2 и t2
5 20
Введите s3 и t3
40 30
60
sergeykirushev

Плюсы:

- Позволяет легко писать программы почти как на чистом английском, а не ломать пальцы и голову о "++i + ++i", (-1 > (unsigned int) 1 ) и прочих сишных извращений.

- Отсутствие большого количества слов для изучения(Что облегчает задачу в изучении)

- Компилятор Паскаля имеет невысокие аппаратные и системные требования. Это же можно сказать и о софте, который будет выполнен с этого языка программирования.

- При работе с Паскалем очень редко необходимы вставки ассемблера. В основном весь софт подготовлен и готов к работе. Также, стоит отметить открытый исходный код, который доступен к редактированию каждому умельцу.

Минусы:

- невозможность передачи функциям массивов переменной длины.

- отсутствие нормальных средств работы с динамической памятью.

- ограниченная библиотека ввода и вывода.

- Этот язык создали в 60-х годах. Соответственно, в наше время он считается уже устаревшим.

- В действительности очень мало реального ПО.

avn23

1-е Задание:

Program PRG;

var

a, b, c, e, x, y, num, den: real;

function calc( a, b, c, e, x: real ): real;

begin

 num := ((( abs(sin(x ** 3))) + a) * (e ** a));

 den := (exp(ln((b ** 2) + (c ** 2)) / 3));

 y :=  num / den;

 Result := y;

 write('Answer is: ', y);

 writeln();

end;

function entNums (): real;

begin

 write ('Enter a: '); readln (a);

 write ('Enter b: '); readln (b);

 write ('Enter c: '); readln (c);

 write ('Enter e: '); readln (e);

 write ('Enter x: '); readln (x);

 writeln();

end;

begin

   entNums();

calc( a, b, c, e, x );

end.

2-е Задание:

Program  

var wallWid, wallHeight, winHeight, winWid, doorWid, doorHeight, fourWalls, door, win, total: real;

function getFourWalls( wallWid, wallHeight: real ): real;

   begin

       fourWalls := (wallHeight * wallWid) * 4;

       Result := fourWalls;

   end;

function getDoorSize( doorHeight, doorWid: real ): real;

   begin

       door := doorHeight * doorWid;

       Result := door;

   end;

function getWinSize( winHeight, winWid: real ): real;

   begin

       win := winHeight * winWid;

       Result := win;

   end;

function getWalls(): real;

   begin

       total := (fourWalls - ( door + win )) / 10000;

       Result := total;

       write(' You need ', total, ' m² of wallpaper!');

       writeln();

   end;

function enterSizes(): real;

   begin

       writeln();

       write (' Enter width of the wall (in cm): '); readln (wallWid);

 write (' Enter height of the wall (in cm): '); readln (wallHeight);

 write (' Enter width of the window (in cm): '); readln (winWid);

 write (' Enter hight of the window (in cm): '); readln (winHeight);

 write (' Enter width of the door (in cm): '); readln (doorWid);

 write (' Enter height of the doot (in cm): '); readln (doorHeight);

 writeln();

   end;

begin

   enterSizes();

   getFourWalls( wallWid, wallHeight );

   getDoorSize( doorHeight, doorWid );

   getWinSize( winHeight, winWid );

   getWalls();

end.

Блок-схемы легко можешь составить глядя на коды программ)

Удачи)

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу 7 класс: автомобиль проезжает первую часть пути длиной в s1 км за t1 мин, участок пути длиной s2 км за t2 мин, и участок пути s3 км за t3 мин. найдите среднюю скорость автомобиля в км\ч.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

krikatiy
shturman-765255
Konstantinovna Ilyukhin1618
Марина Федорович924
Mariya Filippov
Andrei Morozov
КристинаАлександр
Aivazyan
amaraks67
d892644813661946
misie1974
Arsen0708
Евгений
lbondareva
Mexx9050