Nastyaches4
?>

Написать программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечетными значениями. на экран выводится исходный массив, массив с нечетными значениями и произведение. pascal

Информатика

Ответы

ars-trushakova

program fantscrin;

 const n = 10;

 var a: array [1..n] of integer;

        i,s:integer;

Begin

 for i:=1 to n do

   a[i]:= random(11)+1;

 for i:=1 to n do

   write(a[i], '  ');

 p:=1;

 for i:=1 to n do

   if (i mod 2 <> 0) then

                           begin

                                p:=p*a[i];

                                write(a[i], '  ');

                            end;

 writeln('');

 writeln('Произведение = ',p);

End.

proh-dorohova5244

гиперссылка в PowerPoint – это инструмент мобильного перехода между страницами, между презентациями и пр. ресурсами или выход на web-страницы. Этот элемент достаточно хорошо освоен педагогами. ... Триггер – это интерактивный механизм анимации, позволяющий задать автономное действие для любого элемента презентации и управлять ими на слайде в любой последовательности. Благодаря триггерам можно добиться большей динамики при проведении занятий, организовать уникальные дидактические игры, тренажёры, тестеры, в том числе и для работы на интерактивной доске. ... При нажатии на один объект-триггер может проигрываться анимация нескольких объектов одновременно или цепочкой

lyubavalev8

#include "pch.h"

#include

#include

using namespace std;

double f(double x)

{

double m = -7 * pow(x, 3) - 5.8*x - 4;

return m;

}

int main()

{

double a = -1; double b = 2;

flag1:

double c = 0.5*(a + b);

if (f(c) == 0)

cout << "The result is " << c << endl;

if (f(c)*f(a) < 0)

{

b = c;

goto flag1;

}

if (f(c)*f(b) < 0)

{

a = c;

goto flag1;

}

if (c >= a && c <= b)

cout << "The solution belongs to the interval" << endl;

else

cout << "The solution doesn't belongs to the interval";

return 0;

}

Тут с флагами. Если не нравятся флаги - перестройте под себя.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая формирует массив из 10 случайных чисел в диапазоне от 1 до 10 и вычисляет произведения элементов массива с нечетными значениями. на экран выводится исходный массив, массив с нечетными значениями и произведение. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

melnik-738
stsnab
Vladimir-Tamara1359
Tochkamail370
rimmatrotskaia303
skzzkt
dashanna04225
Владимирович_Намик59
alexanderpokrovskij6
houseoftorture138
Bella Sergei
margo929
mixtabak2
dmitryshigin
shumilovs7252