dpodstrel85
?>

Дано 31 число - значения температуры воздуха в марте. числа могут принимать значения от (–20) до 20. опишите на одном из языков программирования алгоритм, который подсчитывает и выводит среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля гарантируется, что хотя бы один день в марте была оттепель. написать программу 27 + лучший ответ

Информатика

Ответы

filantropagv4
Синтаксис классического Паскаля, может получиться так:

//PascalABC.NET v3.3

const n = 31;

var i,c:integer;

td:array[1..n]of real;

sr:real;

begin

for i:=1 to n do begin

  readln(td[i]);

  if td[i]>0 then begin 

    sr:=sr+td[i];

    c:=c+1;

  end;

end;

writeln('Средняя температура в оттепель:',sr/c)

end.

borisrogovpr3407
Не самый лёгкий, но работающий

const  n = 10000;//Не изменяемая по ходу программы переменная
var  a: array[1..n] of integer;  b: array[1..10]of integer;  c: array[1..10]of integer;  i, s, v: integer;
begin  for i := 1 to 10 do //Заполнение массива с числами от 1 до 10    c[i] := i;  for i := 1 to n do //Заполнение массива    a[i] := random(10) + 1; //Делается для того чтобы в массиве не было нулей  for i := 1 to n do    case a[i] of      1: b[1] := b[1] + 1;      2: b[2] := b[2] + 1;      3: b[3] := b[3] + 1;      4: b[4] := b[4] + 1;      5: b[5] := b[5] + 1;      6: b[6] := b[6] + 1;      7: b[7] := b[7] + 1;      8: b[8] := b[8] + 1;      9: b[9] := b[9] + 1;      10: b[10] := b[10] + 1;    End;    for i := 1 to 10 do    for s := 1 to 9 do      if b[s] > b[s + 1] then begin        v := b[s];        b[s] := b[s + 1];        b[s + 1] := v;        v := c[s];        c[s] := c[s + 1];        c[s + 1] := v;      end;  writeln(c[10], ' - их ', b[10]);    end.
Ермакова Ирина674
// PascalABC.NET 3.0, сборка 1156 от 30.01.2016
function Avg(a:array[,] of integer):real;
begin
  var s:=0; var k:=0;
  foreach var e:integer in a do
    if e>0 then begin s+=e; Inc(k) end;
  if k>0 then Result:=s/k else Result:=1e-100;
end;

begin
  var A:=MatrixRandom(4,4,-50,50); Writeln(A);
  Writeln('Среднее арифметическое положительных равно ',Avg(A):0:3);
  var B:=MatrixRandom(5,5,-30,30); Writeln(B);
  Writeln('Среднее арифметическое положительных равно ',Avg(B):0:3);
  var C:=MatrixRandom(4,5,-25,38); Writeln(C);
  Writeln('Среднее арифметическое положительных равно ',Avg(C):0:3);
end.

Тестовое решение:
[[35,35,5,-47],[14,34,35,-13],[25,-5,35,-29],[-7,10,-12,12]]
Среднее арифметическое положительных равно 24.000
[[-12,-17,-10,19,14],[20,17,-27,-2,16],[-3,-21,30,2,10],[5,-3,-17,-3,18],[0,-26,29,1,-22]]
Среднее арифметическое положительных равно 15.083
[[-5,-11,17,-4,15],[15,17,-24,36,15],[-8,-3,-22,28,-25],[-21,6,12,31,-1]]
Среднее арифметическое положительных равно 19.200

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано 31 число - значения температуры воздуха в марте. числа могут принимать значения от (–20) до 20. опишите на одном из языков программирования алгоритм, который подсчитывает и выводит среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля гарантируется, что хотя бы один день в марте была оттепель. написать программу 27 + лучший ответ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gbfedak220
mashuska
keykov35
Sharap
sergeychelyshev197618
beyound2006193
СмыковаДарья1969
tokarevmax
warlordkolomna
SAMSCHOOL96
shurshin6975
mariya
yamalsva45
Yelizaveta1848
korj8
▲