namik120939
?>

Используя оператор case составить программу решения квадратного уравнения, заданного своими коэффициентами a, b и c ( a*x^2 +b*x + c = 0

Информатика

Ответы

alesia1986
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var g:=ArrRandom(31,0,40); g.Println;
  Writeln(g.IndexMax+1)
end.

Пример
38 34 15 11 2 33 12 39 12 0 32 23 7 18 22 31 0 6 19 15 24 37 26 12 7 9 20 25 21 18 20
8

// PascalABC.NET 3.2, сборка 1407 от 18.03.2017

begin
  var y:=ReadArrReal('2008:',12);
  var z:=ReadArrReal('2009:',12);
  var d:=y.Average-z.Average;
  if d>0 then Writeln('2008 теплее')
  else
    if d<0 then Writeln('2009 теплее')
    else Writeln('Оба года имеют одинаковую среднюю температуру')
end.

Пример
2008: -12.7 -10.4 -2.3 5.7 12.5 19.6 24.1 22.8 19.9 17.6 8.2 -7.4
2009: -15.2 -9.4 1.6 7.1 13.5 17.1 26.3 21.4 17.5 14.2 10.1 -12.6
2008 теплее
Кирилл_Гульницкий
Маркированные списки применяются при перечислении или выделении отдельных фрагментов текста. А нумерованные списки полезны в тех случаях, когда нужно определить порядок изложения. 
Создать маркированный список можно двумя
1. В начале абзаца ввести звездочку или знак "больше", а затем нажать Tab или пробел. 
2. Автоматический маркированный список создается так: во вкладке "Файл" выбрать "Параметры". В разделе "Правописание" выбрать "Параметры автозамены". Затем в разделе "Автоформат" установить флажки напротив стилей.
Чтобы создать нумерованный список необходимо:
Написать "1." и поставить пробел или нажать Tab.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя оператор case составить программу решения квадратного уравнения, заданного своими коэффициентами a, b и c ( a*x^2 +b*x + c = 0
Ваше имя (никнейм)*
Email*
Комментарий*
▲