ann-perminova2008
?>

Татьяна ларина, читала очередной французский роман, подсчитала сумму номеров прочитанных страниц. обозначим эту сумму q. написать программу, определяющую номер страницы. (pascalabcnet)

Информатика

Ответы

sn009
Var q,i,s:integer;
begin
readln(q);
s:=0;
i:=0;
while s<q do
 begin
 i:=i+1;
 s:=s+i;
 end;
if s=q then writeln('Страница = ',i+1)
else writeln('Ошибка ввода');
end.

Пример:
5
Страница = 6
vovkiv7864
Сумма страниц q = 1+2+3+4+...+n.
Это арифметическая прогрессия, формула суммы которой известна из математики.
\displaystyle S= \frac{2a_1+d(n-1)}{2}\cdot n; \quad a_1=d=1\to S= \frac{n(n+1)}{2} ; \\ \\&#10;n^2+n-2S=0; \quad D=1+8S; \quad \sqrt D=\sqrt{1+8S} \\ \\&#10;n= \frac{-1\pm \sqrt{1+8S}}{2}= \frac{\sqrt{1+8S}-1}{2}

// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var q:=ReadInteger('q=');
  Writeln('n = ',(Sqrt(1+8*q)-1)/2:0)
end.

Пример
q= 55
n = 10
Aleks120498

технологии записи данных

принцип работы жёстких дисков похож на работу магнитофонов. рабочая поверхность диска движется относительно считывающей головки (например, в виде катушки индуктивности с зазором в магнитопроводе) . при подаче переменного электрического тока (при записи) на катушку головки возникающее переменное магнитное поле из зазора головки воздействует на ферромагнетик поверхности диска и изменяет направление вектора намагниченности доменов в зависимости от величины сигнала. при считывании перемещение доменов у зазора головки приводит к изменению магнитного потока в магнитопроводе головки, что приводит к возникновению переменного электрического сигнала в катушке из-за эффекта электромагнитной индукции.

намагничиваются его области микрозоны

точнее перемагничиваются.

puchkovajulia
Язык c++
Первая задача и вторая в одном проекте. 
#include <iostream>
#include <cstdlib>// включает srand() и rand()
#include <ctime> // содержит time
int main(){
  float mas[79];
  double mult = 1; 
srand(time(NULL));// при каждом запуске будут новые случайные числа
for (int i=0; i<79; i++) mas[i] = 0.1*rand();//заполнение массива случайными числами
// Задача 2: произведение этих элементов:
for (int i=0; i<79; i++) mult*=mas[i];
std::cout << "mult = " << mult << std::endl;
system("pause");
return 0;
}
Третья:
#include <iostream>
#define x 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){ float N[x];
int i;
for (i=0; i<x; i++){ cout << "N[" << i << "]= ";
cin >> N[i];
}
cout << "" << endl;
for (i=0; i<x; i++)
cout << "N[" << i << "] / 2= " << N[i]/2 << endl;
system("pause");
}
Четвертая:
#include <iostream>
#define N 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){
int mas[N], i, j;
for (i=0; i<N; i++){
cout << "mas[" << i << "]= ";
cin >> mas[i];
}
cout << "" << endl;
for (i=0, j=0; i<N; i++)
if (mas[i] < -3) j++;
cout << "summa mas[i] < -3 = " << j << endl;
system("pause");
}
Пятая:
#include <iostream>
#include <cstdlib>// включает srand() и rand()#include <ctime> // содержит time
#define N 5
int main(){
int mas[N], sum=0; 
srand(time(NULL));// при каждом запуске будут новые случайные числа for (int i=0; i<N; i++){
mas[i] = rand();//заполнение массива случайными числами
if (i%2) sum+=mas[i];
}
std::cout<<"sum= " << sum << std::endl;
system("pause");
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Татьяна ларина, читала очередной французский роман, подсчитала сумму номеров прочитанных страниц. обозначим эту сумму q. написать программу, определяющую номер страницы. (pascalabcnet)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Максим_Нина
Sergeevich-irina
Serkova_Elena251
zbellatriks
toxicfish
jim2k
Dimston134877
Nadirovich1317
baeva-larisa8165
zverevahelen
shangina1997507
гайсанов
Galinagol559
Вячеславович-Дмитрий1694
Александрович Владимирович