Program HelloWorld; var S: double; begin writeln('Введите массу тела:'); readln(S); writeln('Масса кислорода и атомов равна:'); S:=S*0.68; writeln(S:15:2); end.
Нана_Елена
26.08.2022
Попробуем записать это сложение "в столбик" 24005 + 2003
26010
Очень приятно, что сложение младших разрядов дает нам 10. Т.е. понятно, конечно, что 5+3 не могут в сумме дать 0 ни в одной "нормальной" системе счисления, следовательно 0 - это последний разряд суммы 10, а единичка пошла переносом в следующий разряд. Но если считать в десятичной системе, 5+3=8. Но не 10. 10-8=2, т.е. сумма получилась на 2 больше. Следовательно, основание системы счисления на 2 меньше, т.е. равно 10-2, т.е. 8. Итак, мы сделали (обоснованно!) предположение, что основание системы счисления равно 8. Посмотрим, все ли цифры можно записать в восьмеричной системе, где допускаются только цифры от 0 до 7? Все. Ну и отлично, задача решена. Остальные разряды суммы в восьмеричной и десятичной системе выглядят одинаково, так что и тут противоречий нет.
ответ: 8
zabrodin
26.08.2022
Попробуем записать это сложение "в столбик" 24005 + 2003
26010
Очень приятно, что сложение младших разрядов дает нам 10. Т.е. понятно, конечно, что 5+3 не могут в сумме дать 0 ни в одной "нормальной" системе счисления, следовательно 0 - это последний разряд суммы 10, а единичка пошла переносом в следующий разряд. Но если считать в десятичной системе, 5+3=8. Но не 10. 10-8=2, т.е. сумма получилась на 2 больше. Следовательно, основание системы счисления на 2 меньше, т.е. равно 10-2, т.е. 8. Итак, мы сделали (обоснованно!) предположение, что основание системы счисления равно 8. Посмотрим, все ли цифры можно записать в восьмеричной системе, где допускаются только цифры от 0 до 7? Все. Ну и отлично, задача решена. Остальные разряды суммы в восьмеричной и десятичной системе выглядят одинаково, так что и тут противоречий нет.
ответ: 8
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Ворганизме человека на долю атомов кислорода приходится 65 % от массы тела. найдите массу атомов кислорода для своей массы тела. составить программу
var S: double;
begin
writeln('Введите массу тела:');
readln(S);
writeln('Масса кислорода и атомов равна:');
S:=S*0.68;
writeln(S:15:2);
end.