Сергеевна-С.А.1549
?>

Составить программу, подсчитать количество положительных и количество четных элементов паскаль

Информатика

Ответы

impulsmc715
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ArrRandom(10,-99,99).Println;
writeln('кол-во положительных: ',a.Where(x->x>0).Count);
write('кол-во четных : ',a.Where(x->x.IsEven).Count);
end.
Larax0819

Объяснение:

1 Система счисления - это ...

а) знаковая система, в которой приняты определённые правила записи чисел.

б) совокупность знаков

в) совокупность правил написания чисел.

2 Переведите число 7^10 из десятичной системы счисления в двоичную и выберите верный вариант ответа.

а) 111^2

в)11^2

б) 112^2

г) 10^2

3 Переведите число 11^2 из двоичной системы счисления в десятичную и выберите верный вариант ответа.

а) 11^10

в) 7^10

б) 3^10

г) 10^10

4 Алгебра логики - это ...

а) раздел математической логики, который изучает высказывания, рассматриваемые со стороны их логических значений (истинности или ложности), и логические операции над ними.

б) раздел математики, который изучает уравнения, содержащие цифры и буквенные обозначения, представляющие величины, подлежащие определению.

в) раздел математики, в котором изучаются формы и законы их измерения.

5 Предложение, относительно которого можно сказать истинно оно или ложно называют:

а) Высказывание;

б) Утверждение;

в) понятие;

г) определение.

6 Для какого из указанных чисел Х истинно выражение

НЕ (х >= 7) И (х < 11)

а) 11 б) 7 в)-3

г) 18

7 Для какого из перечисленных ниже названий стран истинно высказывание:

Первая буква согласная И Третья буква согласная И Последняя буква гласная

а) Люксембург б) Бельгия в) Австрия

г) Греция

8 Выберите высказывания, которые являются истинными.

а) В алфавит двоичного системы счисления входит два числа: 1 и 2

б) Это предложение содержит 5 слов.

в) Русский алфавит содержит 33 буквы.

г) Русский язык считается международным языком для всех стран.

9 Какие из перечисленных высказываний являются ложными?

а) принтер является устройством ввода информации.

б) все повествовательные предложения являются высказываниями

в) Объектами алгебры логики являются высказывания

г) числовые выражения являются высказываются

10.Конъюнкция - это...

а) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться истинным тогда и только тогда, когда оба исходных

высказывания истинны.

б) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться истинным тогда и только тогда, когда оба исходных

высказывания истинны.

в) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться ложным тогда и только тогда, когда оба исходных

высказывания истинны.

г) логическая операция, которая преобразует исходное высказывание в новое,

значение которого противоположно исходному.

11.Дизъюнкция - это ...

а) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться ложным тогда и только тогда, когда оба исходных

высказывания ложны.

б) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться истинным тогда и только тогда, когда оба исходных

высказывания истинны.

в) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться ложным тогда и только тогда, когда оба исходных

высказывания истины.

г) логическая операция, которая объединяет два высказывания в одно новое, которое

будет являться истинным тогда и только тогда, когда оба исходных высказывания

ложны.

12.Инверсия - это ...

а) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться ложным тогда и только тогда, когда оба исходных

высказывания истины.

б) логическая операция, которая преобразует исходное высказывание в новое,

значение которого противоположно исходному.

в) логическая операция, которая объединяет два высказывания в одно новое,

которое будет являться ложным тогда и только тогда, когда оба исходных

высказывания ложны.

г) логическая операция, которая преобразует исходное высказывание в новое,

значение которого будет всегда истинно.

14.Алгоритм - это…

а) конечная последовательность действий, выполнение которых приводит к новой

задаче.

б) бесконечная последовательность команд, выполнение которых приводит к

решению поставленной задачи.

в) конечная последовательность команд, выполнение которых приводит к решению

поставленной задачи.

15.Объект выполнять команды

а) Алгоритм

в) Исполнитель

б) Команда

г) Система команд исполнителя

16.Выберите документ, который является алгоритмом.

а) Правила техники безопасности.

в) Расписание уроков.

б) статья в газете

г) Инструкция по получению денег в банкомате.

17.Выберите представления алгоритма, в котором каждое действие

осуществляется в геометрических фигурах, каждая из которых подразумевает

выполнение определенного действия.

а) Фотография.

в) Схема

б) Картинка

г) Блок-схема.

Новицкий1107

Задачка простая, недавно здесь подобную решал. Чтобы её решить, нужно знать несколько базовых положений.

 

1. Для отображения цветовой гаммы, как правило, исользуется 3 цвета(красный, зелёный, синий).

2. Если для цвета выделено n бит, он может принимать 2^n оттенков. (это чистая математика(комбинаторика)).

3. Как следствие, макс количество цветов в палитре 2^n*2^n*2^n = 2^(3n)

 

Теперь можно решать задачу.

 

Пусть под цвет выделено n бит.

Так как всего цветов 3, на один пиксел будет 3*n бит, Следовательно, общий объем рисунка будет

1024 * 512 *( 3*n) = 512 K *(3*n)  = (1.5*n)Mбита (По определению 2^10 = 1024 = 1K) .

 

Вот, в принципе, и всё!

Но Дальше БОЛЬШИЕ сложности, так как не понятно, что написано в условии, что такое Мб - это мегаБИТ или МегаБАЙТ, поэтому придётся рассматривать 2 случая

1. МегаБИТ.

(1.5*n) = 1.5

n=1, то есть под цвет выделен 1 бит.

Макс количество цветов в палитре

2^(3n) = 2^3 = 8.

Да! всего 8 оттенков.

 

2. МегаБАЙТ, вспомним, что байт=8бит, получим

(1.5*n) = 1.5 *8, 

n=8, то есть под цвет выделен целый байт(8 бит)

Макс количество цветов в палитре

2^(3n)= 2^24= 16777216.

 

Вот и всё.

Да, в реальности, в настоящее время, как правило, под цвет выделено ОДИН БАЙТ, то есть случай 2 полностью соответствует принятому в настоящее время стандарту де-факто и в пикселе 3 байта.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, подсчитать количество положительных и количество четных элементов паскаль
Ваше имя (никнейм)*
Email*
Комментарий*