kiparistop
?>

Известно, что 1 число месяца-день недели среда. составить программу, которая после ввода любого числа в этом месяце выдаёт какой это день недели

Информатика

Ответы

Михайлов
Var d, n: integer;
begin
write('Номер дня недели первого числа месяца (1..7): ');
readln(d);
write('День месяца (1..31): ');
readln(n);
write('Это ');
case (n + d - 2) mod 7 of
0: write('понедельник');
1: write('вторник');
2: write('среда');
3: write('четверг');
4: write('пятница');
5: write('суббота');
6: write('воскресение')
end;
readln
end.
hachatryanlilit1983

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

uses GraphABC;

type point=record

          x,y:integer;

          end;

procedure plitk(x,y,r:integer);

var p:array[1..9]of point;

   a,da:real;

   i:byte;

begin

a:=pi/2;

da:=pi/4;

for i:=1 to 9 do

begin

 p[i].x:=x+round(r*cos(a));

 p[i].y:=y-round(r*sin(a));

 a:=a+da;

end;

polygon(p,9);

end;

var r,i,j,x,y,d:integer;

begin

r:=20;

y:=r;

while y<=windowheight do

begin

 x:=r;

 while x<=windowwidth do

  begin

   plitk(x,y,r);

   x:=x+2*r;

  end;

 y:=y+2*r

end;

end

chizhenkovd9

const n=20;

var a:array [1..n] of integer;

i,max,maxi,min,mini:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

maxi:=1;

min:=a[1];

mini:=1;

for i:= 1 to n do

begin

if a[i]>max then

begin

max:=a[i];

maxi:=i

end;

if a[i]<min then

begin

min:=a[i];

mini:=i

end

end;

writeln;

writeln('Максимальный элемент ',max,' и его номер ',maxi);

writeln('Минимальный элемент ',min,' и его номер ',mini)

end.

Или (если max или min элемент будет не один)

const n=20;

var a:array [1..n] of integer;

i,max,min:integer;

begin

write('Массив: ');

for i:= 1 to n do

begin

a[i]:=random(101)+50;

write (a[i],'  ')

end;

max:=a[1];

min:=a[1];

for i:= 1 to n do

begin

if a[i]>max then max:=a[i];

if a[i]<min then min:=a[i]

end;

writeln;

for i:= 1 to n do

begin

if a[i]=max then writeln('Максимальный элемент ',max,' и его номер ',i);

if a[i]=min then writeln('Минимальный элемент ',min,' и его номер ',i)

end

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Известно, что 1 число месяца-день недели среда. составить программу, которая после ввода любого числа в этом месяце выдаёт какой это день недели
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сергеевна-С.А.1549
stsnab
ver2bit
mdclcompany
Александровна1685
olgaprevisokova302
karpovaveronika196
fixer2006
Reginahappy
iivanov54
Nugamanova-Tatyana840
Николаевна Филиппов1936
igevskoemuseumkec
Galina_Yurevna
themolodoy