Nikolaevich-Svetlana388
?>

Легко но меня не было на уроке написать программу: с клавиатуры вводиться число n. заполнить массив n случайными числами. в массиве может находиться не более 100 элементов. упорядочить массив по возрастанию и сформировать новый массив, каждый элемент которого равен исходному плюс полученному элементу.

Информатика

Ответы

taa19707470
Program massiv;
var M: array [1..100] of integer;
M2: array [1..100] of integer;
a,n,i,i2 : integer;
begin
read (n);
for i:= 1 to n do begin
readln (a);
M[i]:=a;
M2[i]:=a;
end;
for i:= 1 to n do begin
for i2:= i+1 to n do begin
if (M[i]< M[i2]) then begin
a:=M[i2];
M[i2]:=M[i];
M[i]:=a;
end;end;end;
for i:=1 to n do begin
M[i]:= M[i]+M2[i];  
writeln(M[i]);
end;end.
len4ik1986

Відповідь:

Алгоритм— точно визначена послідовність дій, що ведуть від варіацій початкових даних до шуканого результату. При написанні комп'ютерних програм алгоритм описує логічну послідовність операцій.

Алгоритм має такі властивості:

1. Скінченність — алгоритм повинен завершуватися за скінченну кількість кроків.

2. Масовість - застосування конкретного алгоритму для розв'язання цілого класу однотипних задач із різними наборами вхідних даних.

3. Дискретність - можливість розчленування процесу виконання алгоритму на окремі кроки.

4. Елементарність -крок алгоритму має бути елементарним, можливість виконання якого людиною або машиною не викликає сумнівів.

5. Детермінованість - однозначність процесу виконання алгоритму. Результат роботи алгоритму однозначний при однакових наборах вхідних даних.

6. Результативність - алгоритм повинен завжди приводити до певного результату. Він не може закінчувати свою роботу невизначеною ситуацією.

7. Формальність - виконавець алгоритму повинен отримати результат, не вникаючи в його суть. Так, комп'ютери, виконуючи автоматизовані алгоритми, не розуміють суть завдання.

8. Ефективність - алгоритм повинен бути по можливост виконуватися з мінімальними витратами машинного часу та апаратного забезпечення.

За до алгоритму кожний конкретний результат отримується за скінченну кількість кроків зі скінченної множини даних. Якщо для певних початкових даних процес виконання алгоритму завершується з отриманням результату, кажуть, що до таких даних алгоритм застосовний. Проте в деяких ситуаціях процес виконання алгоритму для певних початкових даних продовжується необмежено. Тоді кажуть, що до таких початкових даних алгоритм незастосовний.

Алгоритмізація- це сукупність взаємопов'язаних дій, що виконуються в процесі розробки та обґрунтування алгоритму.

Алгоритмізація включає:

• розчленування обчислювального процесу на автономні кроки;

• формальний запис змісту кожного кроку обчислювального процесу;

• визначення порядку виконання виділених кроків;

• перевірку правильності роботи алгоритму при реалізації заданого методу обчислення.

Існує кілька в запису алгоритмів:

• словесна форма алгоритму;

• словесно-формульний запис алгоритму;

• графічний запис алгоритму б, що використовує псевдокоди запису алгоритмів повинні відповідати таким вимогам:

• забезпечувати компактний і наглядний запис алгоритму;

• бути якомога зрозумілішим і потребувати мінімуму додаткових пояснень;

• містити строгі правила запису алгоритму, щоб уникнути неоднозначності розуміння відповідних записів;

• забезпечувати достатньо формальний перехід на мови програмування високого рівня.

При записі алгоритму у словесній формі існує загальна методика: кожний алгоритм повинен мати ім'я, що розкриває його зміст. Необхідно позначити початок і закінчення алгоритму, описати вхідні та вихідні дані, що є результатом роботи алгоритму, передбачити команди, що дозволять виконувати певні дії над введеними даними.

Словесно-формульный запис алгоритму відбувається за до слів та формул та, як правило, розкриває зміст етапів виконання алгоритму на професійній мові предметної області в довільній формі. Алгоритм повинен бути записаний так, щоб зміст фрази однозначно визначався її формою.

Графічний запис алгоритму відбувається за до спеціальних графічних схем алгоритмів — блок-схем. Блок-схема алгоритму є системою зв'язаних геометричних фігур з коротким словесним доповненням. Кожна з фігур відображає один крок розв'язку задачі й називається блоком. Послідовність виконання кроків вказується стрілочками, що їх з'єднують. Усередині блоків проводять формалізовані записи, що розкривають зміст виконуваних операцій. У схемі блоки намагаються розміщувати зверху вниз, у порядку їх виконання. Для наочності операції різного виду відображаються на схемі різними геометричними фігурами:

Пояснення: З Вас ♥

grebish2002

Объяснение:

При обращении к ячейке можно использовать описанные ранее ВЗ, А1:G9 и т. д. Такая адресация называется относительной. При ее использовании в формулахExcelзапоминает расположение относительно текущей ячейки. Так, например, когда вы вводите формулу =B1+B2 в ячейку В4, тоExcelинтерпретирует формулу как "прибавить содержимое ячейки, расположенной тремя рядами выше, к содержимому ячейки, расположенной двумя рядами выше".

Если вы скопировали формулу =В1+В2 из ячейки В4 в С4, Excelтакже интер­претирует формулу как «прибавить содержимое ячейки, расположенной тремя ряда­ми выше, к содержимому ячейки двумя рядами выше». Таким образом, формула в ячейке С 4 примет вид =С1+С2.

Если при копировании формул вы пожелаете сохранить ссылку на конкретную ячейку или область, то вам необходимо воспользоваться абсолютной адресацией. Для ее задания необходимо перед именем столбца и перед номером строки ввести символ $. Например: $В$4 или $C$2:$F$48 и т. д.

Смешанная адресация. Символ $ ставится только там, где он необходим. Например: В$4 или $С2. Тогда при копировании один параметр адреса изменяется. а другой — нет.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Легко но меня не было на уроке написать программу: с клавиатуры вводиться число n. заполнить массив n случайными числами. в массиве может находиться не более 100 элементов. упорядочить массив по возрастанию и сформировать новый массив, каждый элемент которого равен исходному плюс полученному элементу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rytikovabs
kzhgutova
SitnikovYurii5
opal19575
polikarpov-70
Bordo
optikmir
bas7572513
karpovaveronika196
is926582086060
ooo-krasa
zeltos384
Лилия-Карпухина337
utburt
kotovayaanastasia2069
▲