я просто ищу все простые числа в диапазоне от 1 до n с решето эратосфена, а далее просто сравниваю вектор с простыми числами.
мой пример решения:#include
#include
using namespace std;
int main()
{
int n;
cin > > n;
vector prime (n+1, true);
prime[0] = prime[1] = false;
for (int i=2; i*i< =n; ++i)
if (prime[i])
for (int j=2; j< =n/i; j++)
if (prime[i*j]) prime[i*j] = false;
for(int i = 0; i < prime.size(); ++i)
{
for(int j = i; j < prime.size(); ++j)
{
if(prime[i]& & prime[j])
if(i+j==n)
cout < < i < < " " < < j < < endl;
}
}
cin.get();
cin.get();
}
"Написать программу,которая вводит массив из N целых чисел и выводит на экран элементы с чётными индексами(индексация начинается с нуля). Протестировать программу на произвольных массивах размерностью 5 и 8 элементов."
Для программы с 8-ми элементным массивом нужно const int n = 5 изменить на const int n = 8
#include <iostream>
using std::cout;
using std::cin;
using std::endl;
int main()
{
const int n = 5;
int a[n];
cout << "Enter 5 numbers: ";
for(int i = 0; i < n; i++)
{
cin >> a[i];
}
for(int i = 0; i < n; i++)
{
if(i % 2 == 0)
{
cout << a[i] << ' ';
}
}
cout << endl;
return 0;
}
Поделитесь своими знаниями, ответьте на вопрос:
80 может быть несколько вариантов ответа 2 - информация и информационные процессы 1. что изучает информатика? любые процессы и явления, связанные с информацией программирование для компьютеров взаимосвязь явлений в природе компьютерные технологии методы решения 2. отметьте все верные высказывания. информация нематериальна информация - это отражение реального мира информация характеризует разнообразие при получении информации уменьшается неопределенность знаний существует строгое определение информации 3. отметьте виды информации, которые компьютер пока не умеет обрабатывать. запах звук речь человека вкус фотографии 4. выберите процессы, которые можно назвать обработкой информации. шифрование передача информации хранение данных сортировка списка поиск в базе данных 5. отметьте все верные высказывания. информация может существовать только вместе с носителем хранение информации - это один из информационных процессов для того, чтобы извлечь информацию из сообщения, человек использует знания обработка информации - это изменение её содержания при записи информации изменяются свойства носителя 6. что такое кодирование? средство поиска информации запись информации в другой системе знаков искажение информации изменение вида информации изменение количества информации 7. какая фраза может служить определением сортировки? выбор нужных элементов расстановка элементов списка в заданном порядке расстановка строк по алфавиту изменение порядка элементов удаление ненужных элементов 8. как называется изменение свойств носителя, которое используется для передачи информации? ответ: введите строку 9. как называются знания, которые представляют собой факты, законы, принципы? в ответе введите прилагательное во множественном числе. ответ: введите строку 10. как называются знания, которые представляют собой алгоритмы решения некоторых ? в ответе введите прилагательное во множественном числе. ответ: введите строку 11. как называют представления человека о природе, обществе и самом себе? ответ: введите строку 12. отметьте все верные высказывания. полученная информация зависит от знаний получателя полученная информация зависит только от принятого сообщения получение информации всегда увеличивает знания знания увеличиваются только тогда, когда полученная информация частично известна одна и та же информация может быть представлена в разных формах 13. как называют информацию, зафиксированную (закодированную) в некоторой форме, в частности, в компьютерных информационных системах? ответ: введите строку
1компьютерные технологии
2это отражение мира
3вкус и запах
4поиск в базе данных