ЕлизаветаВладимирович
?>

Pascal abc.net нужна ! 8) даны натуральное число n и вещественные числа a1, a2, …, an. найти количество вещественных чисел, которые больше своих соседей, т. е. предшествующего и последующего. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000 во второй строке через пробел записаны n вещественных чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество вещественных чисел, которые больше своих соседей. пример исходные данные 9 3 -1 12 5 -17 5 2 15 -5 результат 3 9) даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai, равных между собой. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai, равных между собой. пример исходные данные 9 3 -1 -1 5 -17 5 2 2 -5 результат 2 10. даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai , являющихся четными числами. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai , являющихся четными числами. пример исходные данные 10 3 0 4 5 -17 5 2 14 -5 результат 2

Информатика

Ответы

Aleksandrovna Kolesnik1764
8)
// PascalABC.NET 3.3

begin
  var n:=ReadInteger();
  var a:=ReadArrReal(n);
  var k:=a.Where((x,i)->(i>0)and(i<n-1)and
    (a.ElementAt(i)>a.ElementAt(i-1))and(a.ElementAt(i)>a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 12 5 -17 5 2 15 -5
3

9)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i)=a.ElementAt(i+1))).Count;
  Writeln(k);
end.

Пример:
9
3 -1 -1 5 -17 5 2 2 -5
2

10)
begin
  var n:=ReadInteger();
  var a:=ReadArrInteger(n);
  var k:=a.Where((x,i)->(i<n-1)and(a.ElementAt(i) mod 2=0)and(a.ElementAt(i+1) mod 2=0)).Count;
  Writeln(k);
end.

Пример:
10
3 0 4 5 -17 5 2 14 -5
2
yfetyukov
var  mas1, mas2: array[0..9] of integer;  t, k, i, j: integer; 
begin  
readln(t);  
readln(k);  
for j := 0 to 1 do  begin   
      if (j = 1) then writeln();        
                 for i := 0 to 9 do    begin      
                          if(j = 0) then begin       
                                  mas1[i] := random(100);        
                                    write(mas1[i], ' ');       
                                    if mas1[i] > t Then mas1[i] := mas1[i] + 4;      
                              end      
                            else 
                               begin       
                                      mas2[i] := random(100);        
                                      write(mas2[i], ' ');       
                                       if mas2[i] > 10 * K Then         
                                            mas2[i] := mas2[i] + K;      
                                end;    
                       end;       
                  for i := 0 to 9 do     
                         if (j = 0) then 
                               write(mas1[i]) 
                        else 
                                write(mas2[i]);    
               writeln();  
           end;  
readln();
end.

))
istok11
Uses Crt;
const
  n=10;
var
  a,b:array[1..n] of integer;
  i,k,t:integer;
begin
  ClrScr;
  Randomize;
  for i:=1 to n do begin
    a[i]:=Random(50);
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    b[i]:=Random(50);
    Write(b[i],' ')
    end;
  Writeln;
  Write('k t='); Read(k,t);
  for i:=1 to n do begin
    if a[i]>t then a[i]:=a[i]+4;
    Write(a[i],' ')
    end;
  Writeln;
  for i:=1 to n do begin
    if b[i]>10*k then b[i]:=b[i]+k;
    Write(b[i],' ')
    end;
  Readkey
end.

Тестовое решение:
1 6 23 12 47 1 44 24 6 18
31 30 30 29 0 3 43 32 46 21
k t=2 20
1 6 27 12 51 1 48 28 6 18
33 32 32 31 0 3 45 34 48 23

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal abc.net нужна ! 8) даны натуральное число n и вещественные числа a1, a2, …, an. найти количество вещественных чисел, которые больше своих соседей, т. е. предшествующего и последующего. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000 во второй строке через пробел записаны n вещественных чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество вещественных чисел, которые больше своих соседей. пример исходные данные 9 3 -1 12 5 -17 5 2 15 -5 результат 3 9) даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai, равных между собой. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai, равных между собой. пример исходные данные 9 3 -1 -1 5 -17 5 2 2 -5 результат 2 10. даны натуральное число n и целый числа a1, a2, …, an. найти количество пар "соседних" чисел ai , являющихся четными числами. входные данные во входном потоке в первой строке записано число n (1 < = n < = 10000). во второй строке через пробел записаны n целых чисел ai(-10000 < = ai < = 10000). выходные данные в выходной поток следует записать количество пар "соседних" чисел ai , являющихся четными числами. пример исходные данные 10 3 0 4 5 -17 5 2 14 -5 результат 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

adminaa
dksvetlydir
Nadezhdachizhikova7968
severbykova
Альберт Татьяна
info6
Лилит_Шутова
tanysha1990
russstep
eoils-info
tigran87-87
smirnovaL1286
Sharmel26
Georgievich-Zamudinovna2003
marinakmaa86