Sergei1805
?>

Напишите программу вычисления площади параллелограмма по заданному основанию и высоте.

Информатика

Ответы

voloshin238
#include <iostream>
using namespace std;

int main()
{
int a = "без кавычек пишешь цифру"
int b = "тоже другую цифру без кавычек"
int sum = a * b
cout << sum << endl;
return 0;
}
ella-rudenko
1)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
if (i % 3 == 0)
{cout << str[i] << endl;}
}
_getch();
return 0;
}
2)
#include <iostream>
#include <conio.h>
#include <string>
using namespace std;
int main()
{ string str;
getline(cin, str);
for (int i = 1; i < str.length(); i++)
{
 if (i % 2 == 0)
 { if (str[i] != 'a')
  { str[i] = 'a'; }
  if (str[i] != 'b')
  { str[i] = 'b'; }
  if (str[i] != 'c')
  { str[i] = 'c'; }
}
}
cout << str << endl;
_getch();
return 0;}
universal21vek116
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу вычисления площади параллелограмма по заданному основанию и высоте.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

strager338
kseybar
Viktorovna
Chitaia
svetlana-sharapova-762621
sirenashop25
Мелконян1137
artemyanovich8
svetavalera
armentamada1906
Liliya-buc
sayfullinmr
s2010av565
endyurans2ooo
vsbrelok