demakova1969
?>

Составить программу ..: даны 3 отрезка, определить существует ли треугольник.если существует, то найти его площадь.дано: a, b, c. решение а+b больше с; b+cбольше а; с+а больше b. s=корень кв из p(p-a)(p-b)(p-c

Информатика

Ответы

tanyamurashova11352
Program HelloWorld;var a,b,c,s,p:double;begin    a:=3;    b:=4;    c:=5;    if((a+b>c) and (a+c>b) and (b+c>a))       then begin       p:=(a+b+c)/2;       s:=Sqrt(p*(p-a)*(p-b)*(p-c));       writeln(s);       end       else writeln('Error');end.
chermen40
Язык C++.
Решение смотри во вложении.
fursov-da
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40
Bmashutav16
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу ..: даны 3 отрезка, определить существует ли треугольник.если существует, то найти его площадь.дано: a, b, c. решение а+b больше с; b+cбольше а; с+а больше b. s=корень кв из p(p-a)(p-b)(p-c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Станислав Валерий1696
jenn055
Klyucharyova
Vladimirovna1370
anastasiavilina
selena77
uchpaot
viktort889841
mgrunova
Гарик383
len22
natkoff5
maslprod
Dato24043846
Look7moscow