телерепортер успел заснять пилотов, занявших второе и третье места, которые поливали друг друга шампанским. Далее в кадр попал мокрый Хилл, поздравляющий пилота, занявшего второе место. Из этого делаем вывод, что Хилл - 3.
Шумахер и Кулхардт пытались втащить на пьедестал почета пилота, занявшего четвертое место. Так как Хилл уже третий, то из перечисленных остался Алези - он 4
В это время Шумахер с четвертым гонщиком пожимали друг другу руки. В это время 2 и 3 места были на пьедистале, следовательно Шумахер - 1.
Ну и остался Кулхардт - он 2
Решается и первая и вторая
Вывод на скриншотах
#include <iostream>
using std::cout;
using std::cin;
using std::endl;
bool check(int, int);
int main()
{
int a, b, c;
cout << "Enter a, b, c: "; //Вводить через пробел
cin >> a >> b >> c;
//Проверка на упорядоченность
if(a <= b && b <= c)
{
//Если числа являются упорядоченными,
// то вывести на экран удвоенные значения
cout << "The numbers are ordered:\n";
cout << (a * 2) << ' ' << (b * 2) << ' ' << (c * 2) << endl;
}
else
cout << "The numbers are not ordered" << endl;
//Проверка на равенство
if(check(a, b) || check(b, c) || check(a, c))
{
cout << "There are equal numbers" << endl;//Есть равные числа
}
else
cout << "Equal numbers are not" << endl;//Нет равных чисел
return 0;
}
bool check(int x, int y)
{
if(x == y)
{
return true;
}
else
return false;
}
Поделитесь своими знаниями, ответьте на вопрос:
Стадион вмещает m зрителей, билет на футбольный матч стоит p рублей. определить выручку стадиона, если известно, что стадион был заполнен болельщиками на четыре пятых. составить программу
Begin
Readln(m,p);
s:=0,8*m*p;
Writeln(s);
End.