IrinaSolodukhina1495
?>

Дано дві трійки дійсних чисел. у кожній трійці всі числа різні. знайдіть середнє арифметичне максимальних чисел кожної трійки. написать программу на паскале

Информатика

Ответы

adminaa
Program HelloWorld;var a1,b1,c1,a2,b2,c2:integer; s:double;begin    writeln('First');    a1:=5;    b1:=6;    c1:=1;    writeln(a1,'-',b1,'-',c1);    writeln('Second');    a2:=3;    b2:=2;    c2:=8;    writeln(a2,'-',b2,'-',c2);    if(b1>a1)and(b1>c1) then a1:=b1    else    if (c1>a1) then a1:=c1;    if(b2>a2)and(b2>c2) then a2:=b2    else    if (c2>a2) then a2:=c2;    s:=(a1+a2)/2;    writeln(s:0:2);end.
iraimironova
Const
 n = 20;

var
 pos,neg: integer;
 i,k,x: integer;
 ev,un: integer;
 a,b: array [1..n] of integer;

begin
 for i := 1 to n do
   read(a[i]);
  k := 0;
 pos := 0;
 neg := 0;
  for i := 1 to n do
   begin
      ev := 0;
   un := 0;
      x := a[i];
      if x <> 0 then
     if x > 0 then
       if (x < pos) or (pos = 0) then
         pos := x
       else
     else
       if (x > neg) or (neg = 0) then
         neg := x;
      x := abs(x);
      while x <> 0 do
     begin
     if odd(x) then
       un := un + 1
     else
       ev := ev + 1;
     x := x div 10
     end;
      if un = ev then
     begin
     k := k + 1;
     b[k] := a[i]
     end
      end;

 writeln(pos,' ',neg);
 for i := 1 to k do
   write(b[i],' ')
 end.
vfif-804828
Ми́кроэргономика занимается исследованием и проектированием систем «человек-машина».

Ми́диэргономика исследует производственные взаимодействия на уровне рабочих мест и производственных задач. К ведению мидиэргономики относится проектирование структуры организации помещений, планирование и установление расписания работ, гигиена и безопасность труда.

Ма́кроэргономика исследует и проектирует систему в целом, учитывая все факторы: технические, социальные, организационные.

Целью макроэргономики является гармоничная, согласованная и надежная работы всей системы, "как единого организма".

Виды совместимости среды «человек-машина»

Антропометрическая совместимость — учёт размеров тела человека, возможности обзора внешнего пространства, положения оператора при работе.

Сенсомоторная совместимость — учёт скорости моторных операций человека и его реакций на различные виды раздражителей.

Энергетическая совместимость — учёт силовых возможностей человека при определении усилий, прилагаемых к органам управления.

Психофизиологическая совместимость — учёт реакции человека на цвет, цветовую гамму, частотный диапазон подаваемых сигналов, форму и другие эстетические параметры машины.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано дві трійки дійсних чисел. у кожній трійці всі числа різні. знайдіть середнє арифметичне максимальних чисел кожної трійки. написать программу на паскале
Ваше имя (никнейм)*
Email*
Комментарий*