program SumSeq;
{$APPTYPE CONSOLE}
uses
SysUtils;
//const m:Integer ;
var
i, j, m, s:Integer;
n: array of Integer;
begin
s:=0;
Writeln(m);
Writeln('vvedite m');
Readln(m);
SetLength(n,m);
for i:=0 to m do
begin
j:=Random(10);
if j<5
then n[i]:=-1*j
else n[i]:=j;
write(n[i], ' ')
end;
Writeln;
Writeln('To continue push >>ENTER');
Readln;
for i:=0 to m do
begin
if n[i]<0
then s:=s+sqr(n[i])
end;
writeln('s=',s);
readln
{ TODO -oUser -cConsole Main : Insert code here }
end.
Поделитесь своими знаниями, ответьте на вопрос:
Барс решил осмотреть достопримечательности астаны в конце путешествия барс устал и сменил одежду напишите программу которая будет выполнять действия барса использует ветвление и цикл