orinvarostov
?>

Составить программу вычисления суммы элементов массива состоящего из десяти случацных чисел из интервала 0 ; 10

Информатика

Ответы

Диана-Николаевна377
//PascalABC.NET
//Версия 3.3
begin 
    arrrandom(10, 1, 9).Println.Sum.Println;
end.
Irina1435
Последовательности длиной 7, содержащей 5 букв А могут быть следующими:
** (* - любой из символов В или С)
*А*
ААА*АА*
АА*ААА*
А**
** (пока 6 вариантов)
Далее - аналогично:
**А
ААА*А*А
АА*АА*А
А*ААА*А
**А (ещё 5 вариантов)
ААА**АА
АА*А*АА
А*АА*АА
*ААА*АА (ещё 4 варианта)
АА**ААА
А*А*ААА
*АА*ААА (ещё 3 варианта)
А**
*А* (ещё 2)
** (ещё 1)
Итого: 6+5+4+3+2+1=21
Так как на месте * могут быть любые из 2 символов В или С, то это даст ещё по 4 варианта для каждого случая.
Можно здесь, конечно, комбинаторику вспомнить.
Итого: 21*4 = 84
sjmurko

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

m = 0

n = int(input())

for i in range(0, n):

   k = int(input())

   if (k % 5 == 0) and (k > m):

       m = k

print(m)

Объяснение:

Объявим переменную m, где мы будем хранить ответ, равную 0 (так как в задании представлены натуральные числа, а 0 является ближайшим ненатуральным), и запишем ее в начало программы.Теперь можем работать с переменной k. Если остаток от деления на 5 равен 0 (т.е. кратно 5) и значение k больше значения m (т.к. m — наш ответ), то присвоим значение из переменной k переменной m.И в самом конце выводим переменную m — наш ответ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления суммы элементов массива состоящего из десяти случацных чисел из интервала 0 ; 10
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info122
gulsinatahckeeva
chysvv
krasilnikov74
nusupova
Buninilya
hbqhzwtd
osipovasalex5316
serebrennikova99
vitalis79
Oksana-Kirakosyan1301
Геннадьевна Вета560
kot271104
Манько_Панферов
katya860531