sevro3038
?>

Написать программу на языке с. x+t при x^2+ sint> 0, 1 y={ 2x+t^2 при x^2+ sint< 0, 1 x-t при x^2+ sint= 0, 1

Информатика

Ответы

MikhailNechaeva
#include <iostream>
#include <cmath>
using namespace std;
 
int main()
{
int x = 0;
int t = 0;
int y = 0;
cin >> x >> t;
if (pow(x, 2) + sin(t) > 0.1) {
y = x + t;
} else if (pow(x, 2) + sin(t) < 0.1) {
y = 2 * x + pow(t, 2);
} else if (pow(x, 2) + sin(t) == 0.1) {
y = x - t;
}
cout << y;
return 0;
}
Nekrasova

Какой оператор цикла желательно использовать, если известно число повторений тела цикла?

repeat <оператор1, …>until <условие>

while <условие>do <оператор>

for <параметр>:= <начальное значение>to<конечное значение> do<оператор>

2. Используется оператор for i:= -10 to 10 do…

После завершения выполнения тела цикла i = 10

3. Цикл в фрагменте программы

p:=1;

repeat

p:=p*0.1

until p>0.1;

будет исполнен:

1 раз

2 раза

бесконечное число раз

0 раз

3 раза

4. Цикл в фрагменте программы

a:=1;

b:=1;

while a+b<8 do

begin

a:=a+1; b:=b+2

end;

выполнится:

0 раз

3 раза

2 раза

1 раз

бесконечное число раз

5. Какой оператор цикла желательно использовать для записи алгоритмической конструкции, изображённой на схеме?

НЕТ СХЕМЫ. ОТВЕТИТЬ НА ВОПРОС НЕВОЗМОЖНО.

while <условие> do <оператор>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

repeat <оператор1, …> until <условие>

6. Какой оператор цикла желательно использовать, если известно условие выхода из цикла?

repeat <оператор1, …> until <условие>

for <параметр>:= <начальное значение> to <конечное значение> do <оператор>

while <условие> do <оператор>

7. Определите, какое значение будет выведено на экран в результате выполнения приведенной ниже последовательности операторов:

a:=1; b:=1;

while a<=32 do a:=a*2; b:=b*a;  //Обратите внимание! Нет begin end.

write (b)

32

256

64

128

8. Используется оператор for i:= -5 to 9 do…

При первом выполнении тела цикла i = -5

9. Чему равно значение переменной s после выполнения следующего фрагмента программы

Фрагмента программы нет! Задание решить нельзя!

Babushkina27
А) 21 24 27 30 (каждый раз к числу прибавляется 3 единицы)
б) 35 40 45 50  (каждый раз к числу прибавляется 5 единиц)
в) 27 31 35 39  (каждый раз к числу прибавляется 4 единицы)
г) 19 18 16 15 (сначала отнимаешь 2 единицы, потом 1 единицу, и все ещё раз повторяется)
д) 25 36 49 64 (каждый раз увеличиваешь на не чётное число т.е  на 9,11,13,15)
е) 46 47 48 56 (сначала прибавляешь 8 единиц, а затем к двум числам прибавляешь по единице, а после все повторяется сначала)
ж) 55 62 69 75 (каждый раз прибавляешь по 7 единиц)
з) 32 24 16 8 (каждый раз отнимаешь по 8 единиц)
и) 400 500 600 700 (каждый раз прибавляешь по 100 единиц)
к) 312 313 314 412 (случай такой же как и под буквой е) только увеличиваешь сначала сотни, а потом единицы)
л) 312 322 332 412 (это аналогично только сначала увеличиваешь сотни, а потом десятки)
м) 33 65 129 257 ( сначала увеличиваешь на 2 в 4 степени (это 16), потом на 2 в 5 степени (это 32) и т.д.)
н) 12 17 23 30 (каждый раз прибавляешь последующее число от начала счета т.е к числам которые нужно написать сначала увеличиваешь на 4 потом на 5, на 6 и на 7)
о) 48 63 80 99 (точно такой же случай как и под буквой д)
п) 216 343 512 719 ( это все числа в кубе например (1 в кубе это 1), (2 в кубе это 8),(3 в кубе это 27), (4 в кубе это 64), (5 в кубе это 125) ну и так далее)
я надеюсь что не запуталась в этих цифрах)) 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с. x+t при x^2+ sint> 0, 1 y={ 2x+t^2 при x^2+ sint< 0, 1 x-t при x^2+ sint= 0, 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Элизбарян
tarasovs
klimenokvapeshop1408
Мануэлла
pozhidaevgv
Budanov317
Olga1233
alexkortyukov
MikhailNechaeva
AleksandraRuslan504
tat122
Nugamanova-Tatyana840
snopovajulia
mitin228133770
Алёна Геннадьевна98