Андрей Шитенкова
?>

Составьте программу, которая спрашивала бы, какую оценку хочет пользователь для себя за самостоятельную работу по иныорматике, и отвечала бы ему в зависимости от оценок. программа: какую оценку хочется? пользователь: 3, 4 программа: может, ещё подумаешь, и сделаешь на отлично?

Информатика

Ответы

qcrv15312
x = int(input("Какую оценку хочется? "))
if (x == 3) or (x == 4):
print("Может, ещё подумаешь, и сделаешь на отлично?")
elif x == 5:
print("Oтлично")
elif (x <=2) and (x >0):
print("Надо учить!!")
else:
print(False)
Komarovsergeysk

1.А) 3418 = 3∙82+4∙81+1∙80 = 192+32+1 = 22510

   Б) 3416 = 3∙62+4∙61+1∙60 = 108+24+1 = 13310

     В) 34116 = 3∙162+4∙161+1∙160 = 768+64+1 = 83310

   Г) 34.15 = 3∙51+4∙50+1∙5-1 = 15+4+0.2 = 19.210

   Д) E41A.1216 = 14∙163+4∙162+1∙161+10∙160+1∙16-1+2∙16-2 = 57344+1024+16+10+0.0625+0.0078125 = 58394.070312510

2.)A) 356-356=0/2 178-178=0/2 289-88=1/2 44-44=0/2 22-22=0/2 11-10=1/2 5-4=1/2 2-2=0/2 1-0=1=>35610=1011001002.

        356-352=4/8 44-40=4/8 40/8=5 => 35610=5448

         356-352=4/16 22-16=6/16 16=1; => 35610=16416

    Б)514-514=0/2 257-256=1/2 128-128=0/2 64-64=0/2 32-32=0/2 16-16=0/2 8-8=0/2 4-4=0/2 2-2=0/2 1=1 => 51410=10000000102

        514-512=2/8 64-64=0/8; 8-8=0/8; 1=1 =>51410=10028

        514-512=2/16 32-32=0/16 2=2 => 51410=20216

    В)2018-2018=0/2 1009-1008=1/2 504-504=0/2 252-252=0/2 126-126=0/2  63-62=1/2 31-30=1/2 15-14=1/2 7-6=1/2 3-2=1/2 1=1 => 201810 = 111111000102

        2018-2016=2/8  252-248=4/8 31-24=7/8 3=3 201810=>37428

        2018-2016=2/16 126-112=14=E/16=7 => 201810 =7E216

    Г)7654-7654=0/2 3827-3826=1/2 1913-1912=1/2 956-956=0/2 478-478=0/2 239-238=1/2 119-118=1/2 59-58=1/2 29-28=1/2 14-14=0/2 7-6=1/2 3-2=1/2=1 =>765410=11101111001102

             7654-7648=6/8 956-952=4/8 119-112=7/8 14-8=6/8=1=>765410=167468

        7654-7648=6/16 478-464=14=E/16 29-16=15=D/16=1 => 765410=1DE616

      Д)78-78=0/2 39-38=1/2 19-18=1/2 9-8=1/2  4-4=0/2 2-2=0/2=1=>10011102=7810

        78-72=6/8 9-8=1/8=1=>7810=1168

         78-64=14=E/16=4 =>7810=4E16

Я просто сам сейчас это решаю)

Артур

(p + q) \div (r + s) - p \times q \div (r \times s)

\sqrt{(x + 1) \div (x - 1)} + 18 \times x \times {y }^{2}

program название;

var a, b, s, p:integer;

begin

writeln ('Введите число a');

readln (a);

writeln ('Введите число b');

readln (b);

s:=a+b;

p:=a*b;

writeln ('Сумма чисел равна:', s);

writeln (Произведение чисел равно:', p);

end.

Объяснение:

/ - деление.

* - умножение.

sqrt - квадратный корень (всё что будет в корне заключается в скобки).

sqr - квадрат (всё что возводится в квадрат заключается в скобки).

В начале вводишь данные с клавиатуры (значение переменной a и значение переменной b).

Переменной s присваивается сумма переменных a и b.

Переменной p присваивается произведение переменных a и b.

Затем, выводится ответ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая спрашивала бы, какую оценку хочет пользователь для себя за самостоятельную работу по иныорматике, и отвечала бы ему в зависимости от оценок. программа: какую оценку хочется? пользователь: 3, 4 программа: может, ещё подумаешь, и сделаешь на отлично?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kotsur
xeniagolovitinskaya4546
vova00831
karkh267
Михайлов
btatarintsev
diannaevaaa
bespalovaannaanna
karinasy4ewa
okarp
chuev4444
delo1005
viz-art-pnz1664
Дмитрий_Владимирович1162
ckiras9
▲