Рощак_Ольга573
?>

С++.дана целая матрица а(n, m составить программу подсчета среднего арифметического значения матрицы. найти отклонение от среднего у элементов каждой строки. алгоритм составил, всё по формуле, но вот почему-то выводит не точный результат, иногда вообще выводит бред.

Информатика

Ответы

goldservicepro
Если вам важна точность вычисления данных вплоть до сотых или тысячных надо использовать типы с плавающей точкой, но не везде а только там где над ними проводят любые арифметические действия
mariia39
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
gumirovane2294
Чтобы было удобнее, располагаем перед собой алфавит:


и действуем по указанному правилу:
берём букву из слова и по алфавиту смотрим, какая буква идёт третьей после нашей буквы
если упёрлись в конец алфавита- продолжаем счёт с начала алфавита (движемся по кругу)
чтобы это было удобнее, я запишу алфавит сразу с добавленными буквами в его конце:


такое действие выполняем для каждой буквы в слове

Итак, шифруем слова:
ИНФОРМАЦИЯ => ЛРЧСУПГЩЛВ
КОМПЬЮТЕР => НСПТБХЗУ
ЧЕЛОВЕК => ЪЗОСЕЗН

А вообще, для человека такое преобразование не очень удобно делать, поэтому для большего объёма текста проще было бы составить программу, или таблицу в Экселе, которая бы выполняла нужные действия с текстом.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++.дана целая матрица а(n, m составить программу подсчета среднего арифметического значения матрицы. найти отклонение от среднего у элементов каждой строки. алгоритм составил, всё по формуле, но вот почему-то выводит не точный результат, иногда вообще выводит бред.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maksimovskiy7657
gavrilasmax05
mashere59
natabodrikova
tigo1
gallush9
tsigankova2018
A2017
margusha1974
Прошкин_Николай368
avakarica
Viktorovich
АндреевичАндрей
manuchar-formen2
Алексеевич620