goldglobustour725
?>

Написать программу, которая вычисляет сумму двузначных чисел, у которых 1 число больше 2

Информатика

Ответы

narkimry134
Var a,a1,a2,s: integer;
begin
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1>a2 then 
begin
s:=a1+a2;
writeln(s);
end
end.
spz03

Предположим, что строку пользователь вводит в консоли


def f(): #объявляем функцию, которая будет искать количество

   a = input('Введите строку: ') #Переменная а ссылается на то, что пользователь ввел в консоли

   return len(a.split(' ')) #Вызываем метод split(' '), который делает из строки список, где каждый элемент - это слово в строке. Параметром в этом методе является символ, который разделяет слова в строке, в нашем случае - пробел. Уже от этого списка вызываем функцию len, который возвращает длину списка, то есть количество слов


f() #вызываем составленную нами функцию


можно вообще все уместить в одну строку сделав так:

def f():

   return len(input('Введите строку: ').split(' ')) #Чтобы не создавать переменную а, мы применили функцию split сразу к input


f()


или обойтись без новой функции

print(len(input('Введите строку: ').split(' '))) #print выводит то, что было передано через параметр на экран

lulu777

Более удобный, компактный и требующий меньше памяти код, чем у предыдущего ответа.


Пояснение:


1) вводятся два числа и забиваются в значения a и b соответственно.

2)при команды else производится отбор. Если а больше b, то  идет запись, если нет, то идет другое else, где если a меньше b, то идет запись их. В конечном случае, если не выполняется ни то, ни то, то просто выводится, что они равны, т.к больше нет никаких вариантов.


Код:


Program school6;

var a,b:real;


begin

write ('Введите первое число:');

readln(a);

write ('Введите второе число:');

readln(b);


if a>b then

   write ('Первое число больше второго на ', a-b)

 Else

   If a<b then

       write ('Второе число больше первого на ', b-a)

     Else Write('числа равны');

end.


3) сделать программу, которая сравнивает два числа и выводит сообщение с информацией о том какое чис

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет сумму двузначных чисел, у которых 1 число больше 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tofilev
Viktorovna
glebshramko
bellenru
Vasilevskii
victoria-112296363
Виктория1690
billl24
alf206
lechic3
karpovaveronika196
Platon
Качкова1820
ngz55
jgaishun756