Программы на pascal
1)
var
x, y: real;
begin
writeln('Введите х');
readln(x); //Вводим х
y:= sin(sqr(x));
writeln('y = ', y : 0 : 5); {Печатаем значение у с округлением до 5 знаков после запятой}
end.
2)
var
x, y: real;
begin
writeln('Введите х');
readln(x); //Вводим х
if x >= 0 then y:= cos(x) //Если х >= 0, то у = cosx, иначе у = 1 - 2sinx
else y:= 1 - 2 * sin(x);
writeln('y = ', y : 0 : 5); {Печатаем значение у с округлением до 5 знаков после запятой}
end.
Если все правильно, отметь решение как лучшее)
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу: вводят трех целых чисел, вычислить и вывести их среднее арифметическое значение. (pascal)
//Версия 3.3, сборка 1634
begin
write(ReadSeqInteger(3).Average);
end.