marver201040
?>

Напишите программу на паскале, которая сообщает нам: -если оценка 3 или 4 или 5 , то "экзамен сдан" -если оценка 2, то "не сдан", иначе "нет такой оценки"

Информатика

Ответы

sokolowskayaa
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Введите оценку от 2 до 5:');
  case n of
  3..5:Writeln('Экзамен сдан');
  2:Writeln('Экзамен не сдан');
  else Writeln('Нет такой оценки')
  end
end.
ntinyakova
Program proverka;
var a:integer;
begin
write ('Введите оценку: ');
readln (a);
if (a=3) or (a=4) or (a=5) then writeln ('экзамен сдан')
else if (a=2) then write('не сдан')
else write('нет такой оценки');
readln
end.
inna-zub
1)
#include<iostream>
#include<cmath>  
void main() {    
char ch1, ch2;    
int vol1, vol2;          
std::cin >> ch1 >> vol1;        
std::cin >> ch2 >> vol2;                            
if abs(ch1 - ch2) <= 2) && (abs(vol1 - vol2) <= 2)) && ((ch1 != ch2) && (vol1 != vol2))) && !((abs(ch1 - ch2)==1) && (abs(vol1-vol2))==1))             std::cout << "Possible";                    
else            
std::cout << "Impossible";        
}
3)
#include<iostream> 
using namespace std; 
void main() {    
int n,m;
cin >> n,m;
cout<<n;
for(int i=n;i<=m;i++)
cout<<i+2;
}
4)

#include <iostream>
using namespace std; void main(){
int mass[2][4]   //размерность своего массива вписывай.
{
{ 1, 2, 3, 4 },  //вписывай свои числа.
{ 1, 2, 3, 4 }  
};

for (int i=0 ; i<2;++i)
{
for (int j=0 ; j<4;++j)
{
if(mass[i][j]<0)
 cout<<mass[i][j];
}
}
system("pause");
}

 
ruslanchikagadzhanov
// PascalABC.NET 3.0, сборка 1128
procedure Convert(V:array of integer);
begin
  for var i:=0 to V.Length-1 do
    if V[i]>9 then V[i]:=9
    else
      if V[i]<5 then V[i]:=5
end;

procedure Develop(c:char; k:integer);
begin
  WritelnFormat('*** Массив {0} ***',c);
  var a:=ArrRandom(k,-5,15);
  Write('исходный : '); a.PrintLn(',');
  Convert(a);
  Write('результат: '); a.PrintLn(',');
end;

begin
  var m:=ReadInteger('Количество элементов в массиве A:');
  var n:=ReadInteger('Количество элементов в массиве B:');
  Develop('A',m);
  Develop('B',n)
end.

Тестовое решение:
Количество элементов в массиве A: 15
Количество элементов в массиве B: 10
*** Массив A ***
исходный : 6,5,-5,9,1,0,-3,9,13,12,-4,8,11,14,-5
результат: 6,5,5,9,5,5,5,9,9,9,5,8,9,9,5
*** Массив B ***
исходный : 5,12,12,4,7,9,7,-3,-1,-2
результат: 5,9,9,5,7,9,7,5,5,5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на паскале, которая сообщает нам: -если оценка 3 или 4 или 5 , то "экзамен сдан" -если оценка 2, то "не сдан", иначе "нет такой оценки"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pifpaf85
Shpunt-86
SaraevaTretyakov1941
МАМОНОВА-андрей
ekaizer
alexandergulyamov
ooozita5
drozd228758
klkkan
Маринова
orgot9
info4632
Yurii537
Coffee3862
ganul