Agadzhanyan-Ekaterina
?>

На с++ натуральное число называется автоморфным, если оно равно последним цифрам его разряда(25^2=625) напишите программу которая вводит натуральное число n и выводит все, автоморфные , не превосходящие n

Информатика

Ответы

yurogov61
#include <iostream>

int main() {
  long n;
  std::cin >> n;

  long power = 10;
  for (long i = 1; i <= n; i++) {
    if (power <= i) {
      power *= 10;
    }
    if (i * i % power == i) {
      std::cout << i << " ";
    }
  }
  return 0;
}
Amelin-Alipova
//Вот программа, которая кодирует слова в системах счисления от 2 до 10
//Первый ввод - число, второй - система счисления
//Pascal ABC.NET v3.0

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

begin
readln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

//Слово Программа она кодирует как 11001111-11110000-11101110-11100011-11110000-11100000-11101100-11101100-11100000-
aguliaeva
Const
  MAX_SIZE = 10;
 
var
  a: array[1..MAX_SIZE] of integer;
  i, size: integer;
 
procedure delete_odd_elements();
var i, j: integer;
begin
  i := 1;
  repeat
    if odd(a[i]) then
    begin
      dec(size);
      for j := i to size do
        a[j] := a[j + 1]
    end
    else inc(i);
  until i > size;
end;
 
begin
  writeln('Исходный массив: ');
  size := MAX_SIZE;
  for i := 1 to size do
  begin
    a[i] := random(100);
    write(a[i] : 3);
  end;
  delete_odd_elements;
  writeln;
  writeln('Полученный массив: ');
  for i := 1 to size do
    write(a[i] : 3);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На с++ натуральное число называется автоморфным, если оно равно последним цифрам его разряда(25^2=625) напишите программу которая вводит натуральное число n и выводит все, автоморфные , не превосходящие n
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tochkamail7
Elshel8694
krisrespect
sherifovaelina
irinaastapova2011
multikbo3049
m79857860146895
ykolkova76
priemni451
Aleksei806
Мартынова_Ринатовна1657
rina394992
Liliya_Ivanova
svetlanadianowa
mel9152480522