Газинурович
?>

Найти количество двузначных чисел оканчивающихся на 7. составить программу в pascal.

Информатика

Ответы

Mbkozlov6
Var count, i: integer;
begin
  count := 0;
  for i := 10 to 99 do
    if i mod 10 = 7 then
      count := count + 1;
  writeln(count);
end.
nnbeyo
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Range(17,99,10).Count.Println
end.

Результат
9
Grishanin

1. Например: смотреть д/з, играть в игры, смотреть видео уроки и т.д.

2. Учителя могут искать тесты/контрольные работы что-бы их провести в классе, так же они могут смотреть информацию для какого либо урока. Старшие могут смотреть что то по работе или то что нужно им сделать для своего ребёнка например-призентацию и т.д.

3. По интернету можно смотреть видео уроки, д/з, информацию для доклада/сообщения в школу.

4. Иногда как, бывает хорошо, а бывает плохо, одна причина почему очень неприятно-мошеники в интернете которые всех обманывают.

Вот мой ответ удачи

victoriapetrs

Python 3.7

import re

import string

def clrStr(strng: str) -> str:

   return re.sub(r' +', ' ', re.sub(rf'[{string.punctuation}]|\n', '', strng))

raw_string = input()

clean_string = clrStr(raw_string)

print(max(clean_string.split(' '), key = lambda p: len(p)))

И никаких велосипедов с перебором всего списка слов в цикле.

Объяснение:

Да, я специально решил эту задачу не так, как просят в условии. Ведь в условии вам максимально разжевали подход к решению. Но, стоит заметить, что по дурацки. Питоньи списки можно перебирать циклом вида for item in list, не обращаясь к исходному списку по индексам. Так же функция max() может принимать аргумент key, который является функцией, с которой интерпретатор будет выбирать максимум из указанного списка.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти количество двузначных чисел оканчивающихся на 7. составить программу в pascal.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

igevskoemuseumkec
Rjkjneirbyf555
Anzhelika-Bulanov802
kapi30
sav4ukoxana7149
danceplusru
Platon
martinzdraste
arturcristian
silantyevevgeny
docvet4
sve707ta
kuchino09
yastrik
mixtabak2