endyurans2ooo
?>

Паскаль дана строка, состоящая ровно из двух слов, разделенных пробелом. переставьте эти слова местами. результат запишите в строку и выведите получившуюся строку. при решении этой нельзя пользоваться циклами и инструкцией if.

Информатика

Ответы

Maloletkina-marina2
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString.ToWords.Reverse; s.Println
end.

Паскаль дана строка, состоящая ровно из двух слов, разделенных пробелом. переставьте эти слова места
zaseche99
Var s, s1, s2, probel: string;
dlina, probelPos: integer;
begin

readln(s);

probel := ' ';
probelPos := pos(probel, stroka);
dlina = length(s);

s1 := copy(s, 1, probelPos-1);
s2 := copy(s, probelPos+1, dlina);
s := s2 + probel + s1;

writeln(s);

end.
Ladyby6224

Язык Паскаль.

Program Ski;

const n=5; {длина массива}

var: a:array [1..n] of integer; i,s:integer;

begin

For i:=1 to n do begin

                          Writeln('vvedite element massiva nomer ',i);

                          Read(a[i]);

                        end;    {Тут мы просим пользователя ввести элементы}

s:=0; {s - это указанная тобой сумма. Мы ее соответственно обнуляем сначала}

for i:=1 to n do begin

                          if a[i] mod 10=0 then s:=s+a[i];  

                       end;    

 

{ берем каждый элемент массива, и проверяем, делится ли он на 10 без остатка(mod- это остаток от деления на указанное число). Если все в порядке, тогда прибавляем число к общей сумме }

 

Writeln('summa elementov ravnih nulu ',s);  {пишет ответ}

readln; {чтобы сразу не закрывалась программа}

end.

 

Если возникнут вопросы или появится еще подобное задание для решения, пиши прямо в личку. Мне все равно делать нечего )

alazaref

Реализация №1

#include <iostream>

using namespace std;

int main()

{

int summ = 0, a;

do

{

cin >> a;

if (a != 0 && a%2==1 && a>=10 && a<=99)

{

summ += a;

}

else

cout << summ << endl;

} while (a != 0);

return 0;

}

Реализация №2 (0 складывается, но на результат не влияет)

#include <iostream>

using namespace std;

int main()

{

int sum=0, a;

cin>>a;

for(sum=0;a!=0;cin>>a)

{

if(a%2==1 && a>=10 && a<=99)

sum+=a;

}

cout<<sum;

return 0;

}


На с++Напишите программу, которая в последовательности целых чисел определяет сумму двузначных нечет
На с++Напишите программу, которая в последовательности целых чисел определяет сумму двузначных нечет

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль дана строка, состоящая ровно из двух слов, разделенных пробелом. переставьте эти слова местами. результат запишите в строку и выведите получившуюся строку. при решении этой нельзя пользоваться циклами и инструкцией if.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ddobrov32133
Look7moscow
Ольга1915
Pogosyan Nataliya
chetverikovalex3738
iptsr4968
mail9
MikhailSvetlana
СветланаВАЛМОС
S.V. Zhoraevna1677
Zolotnik974620
Андрееевич787
Dmitriy793
Tkachenko1050
proh-dorohova5244