aerendzhenova5
?>

Написать программу, которая вычисляет сумму первых n целых положительных чётных чисел. паскаль

Информатика

Ответы

coleslow12
1)
// PascalABC.NET 3.3

begin
  var n:=readInteger;
  writeln(SeqGen(n,2,x->x+2).Sum);
end.

2)
var n,s,i:integer;
begin
readln(n);
s:=0;
for i:=1 to n do s:=s+2*i;
writeln(s);
end.

Пример:
5
30
krikatiy
Program Task;
Const N = 499; M = 1;
Var A: Array [1..N, 1..N] of Boolean;
i, j, x, y, t: Integer;
b: Boolean;
Begin
Randomize;
While i < M Do
Begin
x := Random(N) + 1;
y := Random(N) + 1;
If A[x, y] = False Then
Begin
A[x, y] := True;
i := i + 1;
End;
End;
While b = False Do
Begin
b := True;
For i := 1 To N Do
For j := 1 To N Do
Begin
If A[i, j] = True Then
Begin
If (i + 1) <= N Then
A[i + 1, j] := True;
If (i - 1) > 0 Then
A[i - 1, j] := True;
If(j + 1) <= N Then
A[i, j + 1] := True;
If (j -1) > 0 Then
A[i, j - 1] := True;
End;
End;
For i := 1 To N Do
For j := 1 To N Do
If A[i, j] = False Then
b := False;
t := t + 1;
End;
WriteLn(t);
ReadLn;
End.
Анастасия1097

1 Виндовс Линукс Мак  OS

2 да можно

3.4. По сути, виртуальная машина – это программа, которая эмулирует на вашем компьютере ещё один компьютер, с теми параметрами, которые вы ему зададите. То есть это компьютер в компьютере :) Для чего это нужно? Причин для использования виртуальной машины на вашем компьютере может быть несколько:

Тестирование дополнительной операционной системы, с целью посмотреть, как она работает, насколько она удобна и каковы её особенности и возможности. Но при этом вы не хотите удалять ту операционную систему, которая уже стоит на вашем компьютере. Передо мной такая задача встала, когда я несколько лет назад решал для себя, стоит ли переходить с Windows XP на Window Я установил на виртуальной машине Windows 7, посмотрел тогда ещё сырую версию этой операционной системы, и в то время принял решение оставить на своём компьютере Windows XP. На Windows 7 я перешёл только после того, как в ней были произведены существенные доработки, протестированы уязвимости и исправлены некоторые ошибки. То же самое сейчас происходит и с Windows 8 – я пока окончательно не перешёл на эту систему и пользуюсь Windows 7, а Windows 8 обитает у меня на виртуальной машине. По сути, благодаря виртуальной машине на моём компьютере может быть одновременно запущено сразу несколько операционных систем, и на мой взгляд, это самая основная цель использования различных виртуальных машин.

Тестирование различных программ, которые по той или иной причине вы не хотите сразу устанавливать на ваш компьютер. Либо вы хотите выбрать из нескольких программ, у которых одинаковый функционал (например, аудио или видео проигрыватели), ту, которая вам больше понравится, но при этом вы не будете захламлять ваш компьютер лишними программами, а всего лишь испытаете их на виртуальной машине.

Запуск потенциально опасных программ. Например, при скачивании какой-либо программы ваш антивирус предположил, что она может быть потенциально вредоносна. Вы можете запустить её сначала на виртуальной машине, чтобы посмотреть, как она работает, и уже затем, если никаких подозрений она у вас не вызовет, можно будет установить её уже непосредственно на вашем компьютере.

Запуск программ, несовместимых с установленной на вашем компьютере операционной системой. Например, какая-то программа может не поддерживаться новыми версиями Windows, а вы уже привыкли работать в ней и она вам очень нужна. Предположим, программа не поддерживается версиями Windows 7 и выше, а работает только в Windows XP. Можно, конечно, в этом случае попробовать использовать режим эмуляции предыдущих версий Windows, но это не всегда срабатывает. Поэтому проще установить Windows XP на виртуальной машине и использовать вашу программу в ней. Ещё сложнее обстоят дела, если программа у вас создана для Linux. В этом случае также наличие виртуальной машины с установленной операционной системой Linux.

5.Parallels Desktop 14. VMware. VirtualBox.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая вычисляет сумму первых n целых положительных чётных чисел. паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

heodbxbbshe
aerendzhenova5
funny-furiya
tol1974656
bristolhouse20151001
alexandrxzx09
dbakun
bei07
Апраксин Владимир897
Faed_Arakcheeva
АлександрАлександровна
alvas12828646
dyatchina63
olimov9
tatianaesipenko