Stryapunina
?>

Составить программу нахождения всех трехзначных чисел, таких, что сумма цифр равна а, а само число делится на в (а и в вводятся с клавиатуры

Информатика

Ответы

morozovalexander90
Var a,b,s,q,w,e:Integer;
begin
Read(a,b);
for s:= 100 to 999 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=a) and(s mod b = 0) then
WriteLn(s);
end;
end.
krasnova1977
Корпоративные требования к почтовой перепискеписьмо состоит из трех частей1. Обращение2. текст письма3. Подпись4. исполнитель или сотрудник для связи с полными координатами(адреса: почтовый,E-mail, IСQ,телефон)
Сетевой этикет
Сетево́й этике́т (сетикет, нетикет — неологизм, является слиянием слов «сеть» (англ. net) и «этикет») — правила поведения, общения в Сети, традиции и культура интернет-сообщества, которых придерживается большинство. Это понятие появилось в середине 80-х годов XX века в эхоконференциях сети FIDO. Некоторые из правил сетевого этикета присутствуют в RFC 1855 (английский вариант).
Правила этикета не являются всеобщими и жестко установленными — в разных сообществах они могут значительно различаться. Так как основная цель этикета состоит в том, чтобы не затруднять общение в сообществе, правила могут устанавливаться исходя из целей сообщества, принятого стиля общения, технических ограничений, и т. д. Некоторые правила записаны, и даже оформляются в виде формального устава, а иногда и просто в виде списка, другие правила нигде не записаны, но известны большинству членов сообщества и строго соблюдаются.
kapi30

а) for, так как наша переменная, которая будет управлять циклом(как принято i ) будет принимать значения от 0 до 9, если начинать цикл с 0. Мы создаем переменную result и помещаем внутри цикла следующее выражение: result += 1/(i + 1). На выходе получим результат данного выражения.

б) В данном случае, можно использовать либо for range based, где выражение цикла выглядит так for (const auto & grade : grades), либо while с условием пока не дойдем до конца списка, зависит какой вид списка мы используем. Я считаю больше подходит for.

в) Думаю for range-based, либо обычный for.

г) ответ как и в б, можно использовать либо for ranged base, либо while, если значения аргументов содержатся в массиве, то тогда for range-based. Если например, тестирование происходит с пользовательского ввода, то тогда удобнее было бы использовать while.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу нахождения всех трехзначных чисел, таких, что сумма цифр равна а, а само число делится на в (а и в вводятся с клавиатуры
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

PoleshchukTatyana
vladimirdoguzov
Mikhail1369
artashhovhan
Vitproficosmetics
виталийВячеславович
nataliarogacheva
nchorich55
sahabiev1987
gusinica23
zmlavra
Дмитриевич_Скрябин931
ПолухинаТененева565
P7Y7V7
Obukhov-Buriko
▲