Lvova_Aleksandr933
?>

1)напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105 2)напишите программу, которая вводит натуральное число n и находит сумму всех натуральных чисел от 1 до n . входные данные входная строка содержит единственное целое число n . выходные данные программа должна вывести сумму натуральных чисел от 1 до введённого числа n . примеры входные данные 100 выходные данные 5050 3)напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . входные данные входная строк содержит два натуральных числа – границы диапазона a и b . гарантируется, что a ≤ b . выходные данные программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] . примеры входные данные 2 5 выходные данные 54 4)напишите программу, которая вводит натуральные числа a , b и n , и выводит на экран n псевдослучайных целых чисел на отрезке [ a , b ] . входные данные входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел n . гарантируется, что a ≤ b . выходные данные программа должна вывести n случайных целых чисел в одной строке, разделив их пробелами. примеры входные данные 10 20 5 выходные данные 10 10 19 12 13 за всё решение 99 ! решить

Информатика

Ответы

v89167233402
1)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
if (a<0)and(b<0) then
 begin a:=-a; b:=-b; end;
if a<0 then for var i:=1 to b do s+=a
else for var i:=1 to a do s+=b;
WriteLn(s);
end.

Пример:
-7 15
-105

2)
var n,s:integer;
begin
Readln(n);
s:=0;
for var i:=1 to n do s+=i;
WriteLn(s);
end.

Пример:
100
5050

3)
var a,b,s:integer;
begin
Readln(a,b);
s:=0;
for var i:=a to b do s:=s+i*i;
writeLn(s);
end.

Пример:
2 5
54

4)
var a,b,n:integer;
begin
Readln(a,b,n);
for var i:=1 to n do write(random(b-a+1)+a,' ');
end.

Пример:
10 20 5
11 12 14 14 18
chernovol1985255

Відповідь:

Дивись фото

Пояснення:

<!DOCTYPE html>

<html>

<head>

  <title>Price</title>

  <meta charset="utf-8">

</head>

<body>

 <p>стоимости переговоров</p>

</body>

<script>

 {/*Написать логическое выражение для определения стоимости переговоров, если стоимость переговоров с 22 часов до 8 часов на 20% ниже, а в субботу и в воскресенье дополнительно предоставляется скидка 10%. */}

 t = +prompt('время разговоров от 0 до 24 часов')

 dt = +prompt('продолжительность разговора в минутах')

s = +prompt('стоимость минуты разговора')

 d = +prompt('день недели от 1 до 7')

 console.log('t=',t,'dt=', dt, 's=', s, 'd=', d)

 function Price (t, dt, d, s) {

  let startTalk = t*60

  let price = 0

  console.log('day = ', d)

 

  for (let i =1; i<=dt; i++){

   let night = false

   let holiday = false

   let p = s

   

   if( (startTalk+i)%1440 === 0 ){

    if (d<7){

     d=d+1

     console.log('day = ', d)

    } else {

     d=1

     console.log('day = ', d)

    }

   }

   if ( (startTalk+i)%1440>=1320 || (startTalk+i)%1440<480){

    night = true

   }

   if ( d === 6 || d===7){

    holiday = true

   }

   if (night){

    p = p - s*0.2

   

   }

   if (holiday){

    p = p-s*0.1

   }

   price = price+p

   

   console.log('стоимости '+ i+'мин. = '+ p.toFixed(2)+'$')

  }

  console.log('fin.price', price.toFixed(2), '$')

  return price.toFixed(2)

 }

 {/*Price(t, dt, d, s)*/}

 alert('стоимости переговоров  ' + '$' + Price(t, dt, d, s))

</script>

</html>


Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
Написать решение логическое выражение в javascript. написать логическое выражение для определения ст
strannaya2018
<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body bgcolor=lightgrey>
<font color=red face="Arial"><h1 align=center>Иванов</h1>
<h2 align=center>Иван Иванович</h2>
</font>
<hr width=50%>
<a href="document2.html">На страницу 2</a>
</body>
</html>

<!DOCTYPE html>
<html>
<head>
<meta charset="UTF-8">
<title></title>
</head>
<body bgcolor=lightgrey>
<font color=blue face="Arial"><h1 align=center>Иванов</h1>
<h2 align=center>Иван Иванович</h2>
</font>
<hr width=50%>
<font face="Times New Roman">
<ul>
Список группы:
<li> Чел1
<li> Чел2
<li> Чел3
<li> Чел4
<li> Чел5
<li> Чел6
</ul>
<ul type=square>
Список отсутствующих:
<li> Чел1
<li> Чел2
<li> Чел3
</ul>
</body>
</html>

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. учтите, что числа могут быть отрицательными. входные данные входная строка содержит два целых числа. выходные данные программа должна вывести произведение введённых чисел. примеры входные данные 6 12 выходные данные 72 входные данные -7 15 выходные данные -105 2)напишите программу, которая вводит натуральное число n и находит сумму всех натуральных чисел от 1 до n . входные данные входная строка содержит единственное целое число n . выходные данные программа должна вывести сумму натуральных чисел от 1 до введённого числа n . примеры входные данные 100 выходные данные 5050 3)напишите программу, которая вводит натуральные числа a и b , и выводит сумму квадратов натуральных чисел в диапазоне от a до b . входные данные входная строк содержит два натуральных числа – границы диапазона a и b . гарантируется, что a ≤ b . выходные данные программа должна вывести одно число – сумму квадратов натуральных чисел из диапазона [ a , b ] . примеры входные данные 2 5 выходные данные 54 4)напишите программу, которая вводит натуральные числа a , b и n , и выводит на экран n псевдослучайных целых чисел на отрезке [ a , b ] . входные данные входная строка содержит три числа, разделённые пробелами: границы отрезка a и b и требуемое количество чисел n . гарантируется, что a ≤ b . выходные данные программа должна вывести n случайных целых чисел в одной строке, разделив их пробелами. примеры входные данные 10 20 5 выходные данные 10 10 19 12 13 за всё решение 99 ! решить
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bchukhraev79
yanagitsina
ГегамБукреев830
yfetyukov
masha812
Dubovitskayae
ainud
Kolokolnikova DANIIL179
Inozemtseva Korolev1271
KovalenkoIL
Шеина
АлександровнаВладлен243
happygal5224
Tarapovskaya
chernovol1985255