skalegin68
?>

Массив содержит четное количество элементов. напишите программу, которая сортирует по возрастанию отдельно элементы первой и второй половин массива. каждый элемент должен остаться в «своей» половине. используйте алгоритм быстрой сортировки. пример: массив: 5 3 4 2 1 6 3 2 после сортировки: 2 3 4 5 1 2 3 6 язык программирования !

Информатика

Ответы

itartdesignprof
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ReadArrInteger(n);
  a:=(a[:n div 2].OrderBy(t->t)+a[n div 2:].OrderBy(t->t)).ToArray;
  a.Println
end.

Пример
n= 8
5 3 4 2 1 6 3 2
2 3 4 5 1 2 3 6
s45983765471717
#include <iostream>
using namespace std;
int main()
{
setlocale (0,"");
int n1,n2,n3,p1,p2,p3;
cout<<"введите количество учеников в каждом классе"<<endl;
cout<<"1-";
cin>>n1;
cout<<"2-";
cin>>n2;
cout<<"3-";
cin>>n3;
    p1=n1/2; if (n1%2!=0) p1++;
    p2=n2/2; if (n2%2!=0) p2++;
    p3=n3/2; if (n3%2!=0) p3++;
cout<<"для первого класса - "<<p1<<endl;
cout<<"для второго класса - "<<p2<<endl;
cout<<"для третьего класса - "<<p3<<endl;
return 0;
}
Roman343247
Простая

Program p;
var ch:real;   
         i:integer;
begin 
ch:=65000; 
For i:= 1993 to 2013 do
      begin   
         ch:=trunc(ch*1.03);   
         Writeln('Численность населения в году №',i+1,' равна ',ch);   
       end;
end.

Для любых данных

Program p;
var year,y1:integer;  
      ch:real;   
      i:integer;
begin
    Write('Введите начальный год: '); 
    Readln(year); 
    Write('Введите конечный год: '); 
    Readln(y1); 
    Write('Введите число населения: ');
    Readln(ch); 
    For i:= year to y1-1 do   
      begin   
          ch:=trunc(ch*1.03); 
          Writeln('Численность населения в году №',i+1,' равна ',ch); 
     end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Массив содержит четное количество элементов. напишите программу, которая сортирует по возрастанию отдельно элементы первой и второй половин массива. каждый элемент должен остаться в «своей» половине. используйте алгоритм быстрой сортировки. пример: массив: 5 3 4 2 1 6 3 2 после сортировки: 2 3 4 5 1 2 3 6 язык программирования !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Сергей_Евгеньевич1255
blagorodovaanna375
antonkovalev89
Yelena Kotova
nickcook424
Сергеевич
pristav9
Алексеевич949
Anna572
yatania-popovich7
milaudina
ale-protasov
diana-020
Arsen0708
Maionova