abramovae
?>

На с++ напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. используйте процедуру. входные данные входная строка содержит целое число n . выходные данные программа должна вывести двоичное представление переданного её числа. примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110

Информатика

Ответы

marvindkc
Держи
--------------------
На с++ напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в д
nzagrebin363
Не знаю, что за автоматизация, но запрос на выборку выглядит так:
SELECT * FROM my_table
или же запрос на выборку с условием
SELECT * FROM my_table WHERE name="kek2255"
при этом еще можно использовать операторы AND(И)  и OR(ИЛИ)
SELECT * FROM my_table WHERE name="Иван" AND first_name="Иванов"
SELECT * FROM my_table WHERE name="Иван" OR name="Дмитрий"
и понятное дело их можно комбинировать
SELECT * FROM my_table WHERE (name="Иван" AND first_name="Иванов") OR (name="Дмитрий" AND first_name="Дмитриев")
Можно выполнять запрос из нескольких таболиц
SELECT t1.*, t2.* FROM my_table AS t1, my_table2 AS t2
WHERE t1.id = t2.id_ref


Здесь:
SELECT - Сам оператор выборки
* - это поля выборки, в данном случае все поля(*) -звездочка это значит все поля, но можно просто перечислить id, name, first_name и т.д. При выборе из 2-х и более таблиц указываются префиксы таблицы - это может быть как полное название таблицы(my_table.id) или псевдоним, которое мы указали (FROM my_table AS t1) t1 - будет псевдонимом и выбррка полей будет таким (t1.id, t1.name ...)
FROM - Обязательное ключевое слово(оператор) означает ИЗ(from) 
WHERE - Не обязательный оператор условия (ГДЕ)
Если перевести запрос на русский язык, то будет как в 1С:)
ВЫБРАТЬ * ИЗ моя_таблица ГДЕ Имя = "Иван"
Надеюсь
romashka17-90
//Pascal ABC.NET 3.1 сборка 1219

Const
 n=5;

Var
 max1,max2,min1,min2,i:integer;
 ar:array[1..n] of integer;
begin
 max1:=integer.MinValue;
 max2:=integer.MinValue;
 min1:=integer.MaxValue;
 min2:=integer.MaxValue;
 for i:=1 to n do
  begin
   readln(ar[i]);
   if (ar[i]<max1) and (ar[i]>max2) then max2:=ar[i] else
   if ar[i]>max1 then
   begin
   max2:=max1;
   max1:=ar[i];
   end;
   if (ar[i]>min1) and (ar[i]<min2) then min2:=ar[i] else
   if ar[i]<min1 then
   begin
   max2:=max1;
   min1:=ar[i];
   end;
  end;
 writeln('Сумма максимумов:',max1+max2);
 writeln('Cумма минимумов:',min1+min2);
end.

Пример ввода:
1
2
3
4
5
Пример вывода:
Сумма максимумов:9
Cумма минимумов:3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На с++ напишите программу, которая переводит переданное её целое число (возможно, отрицательное) в двоичный код. используйте процедуру. входные данные входная строка содержит целое число n . выходные данные программа должна вывести двоичное представление переданного её числа. примеры входные данные 5 выходные данные 101 входные данные -14 выходные данные -1110
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kitoova
llmell6
m79857860146895
terma-msk1
Андрей Шитенкова
galkavik
Шарабанов
Orestov563
Moroshkina-Aristova2011
Svetlana ALLA
mdsazonovatv1173
superniki87
Dmitriy793
lor005148
movlam11
▲