karinasy4ewa
?>

Есть : подсчитать количество “счастливых” шестизначных автобусных билетов, т. е. таких, в номерах которых сумма первых трех цифр равна сумме трех последних. необходимо написать программу в делфи на pascal, используя при этом одномерный массив (или массивы заранее : 3

Информатика

Ответы

IAleksandrovna45
Я не знаком особо с паскалем, но могу направить на путь истинный :b
Кароче..
Подсчет количества:
если билет счастливый count++;
(все логично)
Но как определить счастливый ли билет:
Припустим у нас номер билета лежит в массиве: ticket, то
if ((strval(ticket[0]) + strval(ticket[1] + strval(ticket[2])) == (strval(ticket[3]) + strval(ticket[4]) + strval(ticket[5])))
count++;

strval - преобразовнаие из строки в число. string --> integer
Если синтаксис знаешь, то напишешь прогу, если нет.. то жди ответа других.
konstantin0112
//Dev-C++ (С)

#include <stdio.h>

int main(void)
 {int DepHour,DepMin,DurHour,DurMin,ArrHour,ArrMin;
 scanf("%d %d %d %d",&DepHour,&DepMin,&DurHour,&DurMin);
 if(DepMin+DurMin>=60)
  {ArrHour=DepHour+DurHour+1;
    ArrMin=DepMin+DurMin-60;}
   else
    {ArrHour=DepHour+DurHour;
    ArrMin=DepMin+DurMin;}
   printf("%d:%d",ArrHour,ArrMin);
 return 0;}

//PascalABC.NET 3.2 сборка 1318

Var 
DepHour,DepMin,DurHour,DurMin,ArrHour,ArrMin:integer;
begin
readln(DepHour,DepMin,DurHour,DurMin);
if DepMin+DurMin>=60 then
 begin
  ArrHour:=DepHour+DurHour+1;
  ArrMin:=DepMin+DurMin-60;
 end
 else
 begin
  ArrHour:=DepHour+DurHour;
  ArrMin:=DepMin+DurMin;
 end;
 write(ArrHour,':',ArrMin);
 end.

Пример ввода:
1 40 12 23
Пример вывода:
14:3
kozak8824
ЖИЗНЕННОЙ, СИТУАЦИИ, ПОНАДОБЯТСЯ, ВЫЧИСЛИТЕЛЬНЫЕ
Будешь писать неграмотно лично я и отвечать не буду - обидно за русский язык!!
Вычислительными будем называть такие таблицы, в которых значения некоторых свойств вычисляются с использованием значений других свойств из этой же таблицы.  Вычислительная таблица может содержать итоговую строку (графу). Итоговая строка (графа) имеет заголовок «Итого» или «Всего». В ячейках итоговой строки (графы) размещают суммы чисел из соответствующих граф (строк). Важно, чтобы эти суммы имели смысл.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Есть : подсчитать количество “счастливых” шестизначных автобусных билетов, т. е. таких, в номерах которых сумма первых трех цифр равна сумме трех последних. необходимо написать программу в делфи на pascal, используя при этом одномерный массив (или массивы заранее : 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AlekseiMardanova
Giurievna1977
zdanovich90764
Likhomanova63
milanparipovic864
vovkiv7864
pechatlogo4
postbox
luxoutlet
luxoutlet
julya847
mikchaylovaalex
Gesper63
samirmajbubi
Batishcheva