domtorgvl20082841
?>

Составить программу, которая создает и заполняет массив из 12 целых чисел случайными двузначными числами. вывести массив на экран. если последняя цифра значения элемента массива не равна 0, то поменять порядок цифр данного элемента. для изменения порядка цифр двузначного целого числа на обратный (исходное число 25, результат 52) использовать функцию пользователя.

Информатика

Ответы

Anatolevich_Kulikov1229
PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
Внимание! Если программа не работает, обновите версию!

function DI(n:integer):integer;
begin
  var d:=n mod 10;
  if d=0 then result:=n
  else result:=10*d+n div 10
end;

begin
  var a:=ArrRandom(12,10,99); a.Println;
  a.Transform(t->DI(t)); a.Println
end.

Пример
24 90 73 90 78 53 70 14 46 37 45 45
42 90 37 90 87 35 70 41 64 73 54 54
petrowich076813
На скриншотах
==============
Составить программу, которая создает и заполняет массив из 12 целых чисел случайными двузначными чис
Составить программу, которая создает и заполняет массив из 12 целых чисел случайными двузначными чис
Галстян874

Известны два расстояния: одно в километрах, другое—в футах(1 фут=0,45 м). Какое из расстояний меньше?

Program ss;
uses crt;
var
a,b,c,s,s1: integer;
Begin
clrscr;
Writeln('Введите расстояние в километрах:');
readln(a);
Writeln('Введите расстояние в футах');
readln(b);
writeln('Введите размер одного фута в метрах');
s:=a*1000;
s1:=c*b;

if s>s1 then
begin
write('Расстояние в футах меньше чем в км');
end
else
writeln('Расстояние в км меньше чем в футах');
writeln(' Программа завершена нажмите ');
readln;
End.

Известны две скорости: одна в километрах в час, другая—в метрах в секунду. Какая из скоростей больше?
program EvGeN;
var
kilom: real;
metr: real;
begin
kilom := metr * 1.6;
write('Введите скорость в км\ч: ');
readln(kilom);
write('Введите скорость в м\с: ');
readln(metr);
if kilom < metr then write('скорость в км\ч больше');
if kilom > metr then write('скорость в км\ч меньше');
if kilom = metr then write('скорость в км\ч равна скорости в м\ч');
end.

Даны радиус круга и сторона квадрата. У какой фигуры площадь больше
Program ploshcad;
var R,D,skr,skv:extended;
Begin
write('Введите радиус круга: '); readln®;
write('Введите сторону квадрата'); readln(D);
skr:=Pi*sqr®;
writeln('Площадь круга: ',skr:10:5);
skv:=sqr(D);
writeln('Площадь квадрата: ',skv:10:5);
If skr=skv then
writeln('Площади равный');
If skr>skv then
writeln('Площадь круга больше');
If skv<skr then writeln('Площадь квадрата больше');
readln;
End.

 Известны площади круга и квадрата. Определить:
a) Уместится ли круг в квадрате?
b) Уместится ли квадрат в круге?

Program prim;
Var a,r,s1,s2:real;
Begin
Write('введите площадь круга и квадрата');
Readln(s1, s2);
A:=sqrt(s2);
R:=sqrt(s/3.14);
If (r<a/2) then writeln (' круг уместится в квадрате')
Else writeln (' круг не уместится в квадрате');
If (a*sqrt(2))>(4*r) then writeln ('квадрат уместится в круге')
Else Writeln('квадрат не уместится в круге');
Readln
End.

Даны объёмы и массы двух тел из разных материалов. Материал какого из тел имеет большую плотность.
var v1,v2,m1,m2,p1,p2: real;
begin
writeln('Введите объем и массу первого тела');
readln(v1,m1);
writeln('Введите объем и массу второго тела');
readln(v2,m2);
p1:=v1/m1;
p2:=v2/m2;
if p1>p2 then begin
writeln('Плотность первого тела больше');
end;
if p1<p2 then begin
writeln('Плотность второго тела больше');
end
else if p1=p2 then begin
writeln('Плотности тел равны');
end.

Astrians

Не знаю паскаль, знаю C++ :)

int a, b;

//вводим значения в a и в b (в футах)

cin >> a >> b;

b = b*45;

if (a>b) cout << "В км больше";

else cout >> "В футах больше"; 


 

// тут важен дробный тип 

dooble a, b;

//вводим значения в a и в b (м/c)

cin >> a >> b;

a = a:3.6;

if (a>b) cout << "В км/ч больше";

else cout >> "В м/с больше"; 

}

 

ну а дальше надо уже все по формулам смотреть. 

{

doouble a,b;  

//вводим значения в a и в b стороны

cin >> a >> b;

a=a*a*3.14;

b=b*b;

if(a>b) cout << "Площадь круга больше";

else cout << "Площадь квадрата больше"; 

 

4. не знаю как такое делать, что значит уместиться ли круг в квадрате? Уместится если радиус его меньше чем половина стороны.

 

5.

{

  doouble a,b,c,d;

  cin >> a >> b >>c >>d; // вводим объем и массу;

 a = a/b;

c = c/d;

if(a>c) cout << "Тело 1 имеет плотность больше чем тело 2";

else cout << "тело 2 имеет большую плотность"; 

 

6. не знаю. Но тоже как-то через форумулы. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая создает и заполняет массив из 12 целых чисел случайными двузначными числами. вывести массив на экран. если последняя цифра значения элемента массива не равна 0, то поменять порядок цифр данного элемента. для изменения порядка цифр двузначного целого числа на обратный (исходное число 25, результат 52) использовать функцию пользователя.
Ваше имя (никнейм)*
Email*
Комментарий*