gorodof4292
?>

На с++ напишите программу, которая строит "линию" из знаков '-' заданной длины. используйте процедуру. входные данные входная строка содержит единственное натуральное число – длину линии n . выходные данные программа должна вывести n знаков '-'. примеры входные данные 5 выходные данные

Информатика

Ответы

mayorovmisc6
//g++  5.4.0

#include <iostream>
using namespace std;

void foo(size_t n)
{
    for (int i = 0; i < n; ++i) {
        cout << '-';
    }
}

int main()
{
    size_t n;
    cin >> n;

    foo(n);
}
vasilevich-F
Может быть, так:
uses graphABC;
Begin
setfontcolor(clRed);
writeln('Белеет парус одинокой');
setfontcolor(clBlue);
writeln('В тумане моря голубом!..');
setfontcolor(clDarkOrchid);
writeln('Что ищет он в стране далекой?');
setfontcolor(clDeepSkyBlue);
writeln('Что кинул он в краю родном?..');
setfontcolor(clDeepPink);
writeln('Играют волны - ветер свищет,');
setfontcolor(clMagenta);
writeln('И мачта гнётся и скрыпит...');
setfontcolor(clDarkGreen);
writeln('Увы! он счастия не ищет');
setfontcolor(clLime);
writeln('И не от счастия бежит!');
setfontcolor(clBrown);
writeln('Под ним струя светлей лазури,');
setfontcolor(clIndigo);
writeln('Над ним луч солнца золотой...')
End.
EkaterinaSEMENOV702

Объяснение:

1.Специально организованная структура данных, распознаваемая компьютером как единое целое.

2.Название (до точки, часто также называют именем);

Расширение.

3.Длину имени файла составляет 225 символов. В имени можно использовать пробелы. Запрещено использование следующих СИмволов: "" — вертикальная черта, "\" - обратная черта, двоеточие, знак вопроса, звездочка, кавычка, "<" - треугольная скобка, ">" - треугольная скобка. При использовании файла с длинным именем в программе, не являющейся приложением Windows, имя файла будет усечено до первых шести символов длинного имени без пробелов.

4.Диск представляет из себя одну большую папку (корневой каталог), в которой можно создавать другие папки для хранения файлов. Файл можно создать, редактировать (как содержимое файла, так и название, т.е., переименовать), переместить в другую папку, скопироватьвставить, удалить

5. Во время работы на компьютере с файлами и папками чаще всего проводятся такие действия (операции), как:

Создание.

Файл можно открыть в специальной программе. ...

Изменение содержимого файла (редактирование).

Копирование (создание дубликата файла).

Переименование.

Перемещение.

Архивирование.

Удаление.

6.Удаления, форматирования, ненужного копирования (засорение памяти ПК), изменение формата( в том случае если изменишь на неверный формат этот файл не будет работать), запуска неизвестных программ и открытия файлов без проверки сильным антивирусником

7. Свойство рабочего стола - это его оформление, т.е. можно провести аналогию с обычным столом. Он деревянный, белый. Так же и с компьютерным. Его свойство- это картинка, которая стоит на фоне

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На с++ напишите программу, которая строит "линию" из знаков '-' заданной длины. используйте процедуру. входные данные входная строка содержит единственное натуральное число – длину линии n . выходные данные программа должна вывести n знаков '-'. примеры входные данные 5 выходные данные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Pokupatel
vasearu
Platon
Misyura_Viktoriya1683
Asplaksina
Strelkov567
people33
Demina-Khokhlov584
yurassolo747
coleslow12
hrviko
zdl2008
Самохвалова-Геннадьевна
david-arustamyan1
aniramix
▲