lovel24
?>

Составить программу подсчета кол-ва положительных отрицательных чисел в произвольном числовом ряду решить в паскале

Информатика

Ответы

Posadskii-Sergeevna
Program n_1; 
uses crt;
var a: array [1..5] of integer; 
otr,pol,i: byte;
begin 
for i:=1 to 5 do  begin 
a[i]:=random(10)-5; 
write(a[i]:3);   
 if a[i]>0 then pol:=pol+1 else     
if a[i]<0 then otr:=otr+1; 
end; 
writeln; 
writeln('Положительных: ',pol,'; Отрицательных: ',otr);

end.
Lerkinm
Язык Pascal
    uses
      crt;
    var
      cs1,cs2,res,change:integer;
      TD:string;
    function FromDec(n,r:longint):string;
    var
      s:String;
    const
      digit:string[16]='0123456789ABCDEF';
    begin
      s:='';
      repeat
        s:=digit[(n mod r)+1]+s;
        n:=n div r;
      until n=0;
        FromDec:=s;
    end;
    function ToDec(n:string;r:longint):longint;
    var
      m,i:longint;
    const
      digit:string[16]='0123456789ABCDEF';
    begin
      m:=0;
      while n[1]='0' do
        delete(n,1,1);
      for i:=1 to length(n) do
        m:=m*r+pos(n[i],digit)-1;
      ToDec:=m;
    end;
    begin
      writeln('Введите из какой CC:');
      repeat
        readln(cs1);
      until
        (cs1>=2) and (cs1<=36);
      writeln('Введите число в соответствии с CC:');
      readln(TD);
      writeln('Введите в какую CC:');
      repeat
        readln(cs2);
      until
        (cs2>=2) and (cs2<=36);
      writeln('Перевод из ',cs1,' CC --> ',cs2,' CC:');
      writeln(FromDec(ToDec(TD,cs1),cs2));
    end.
larinafashion829

#include <iostream>

#include <iterator>

#include <vector>

 

using namespace std;

 

int main() {

 int n = 5;

 int m = 6;

 

 vector<vector<int>> a(n, vector<int>(m));

 

 for (int i = 0; i < n; ++i) {

   for (int j = 0; j < m; ++j)

     cin >> a[i][j];

 }

 

 vector<double> ans(m);

 

 for (int i = 0, q = 0; i < m; ++i, ++q) {

   int sum = 0;

   int cnt = 0;

 

   for (int j = 0; j < n; ++j) {

     if (a[j][i] < 0) {

       sum += a[j][i];

       ++cnt;

     }

   }

 

   if (sum)

     ans[q] = sum / (double)cnt;

 }

 

 copy(ans.cbegin(), ans.cend(), ostream_iterator<double>(cout, " "));

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу подсчета кол-ва положительных отрицательных чисел в произвольном числовом ряду решить в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vnolenev
goldenshtein33333
Zeegofer
kampina1
Баранов276
mskatrinmadness
Троцкая-Ивановна
asemchenko
pechinin
Aleksei806
Aleksandrovna1153
kosharikclub
vbnm100584
shalunovroman
Kochereva-Sergei