Daletskaya982
?>

Напишите программу, которая в последовательности целых чисел определяет сумму чётных чисел, принадлежащих интервалу (15, 190) или сообщает, что таких чисел нет (выводит "net" программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 -- признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму чётных чисел, принадлежащих интервалу (15, 190) или вывести "net", если таких чисел нет. пример работы программы: вход: 5 15 25 48 180 196 0 выход: 228 (48+180) язык паскаль

Информатика

Ответы

ukkavtodor6
Var a,s,i :integer;
begin
readln(a);
while a<>0 do begin
readln(a);
if (a >15) and (a<190) and (a mod 2=0) then
s:=s+a;
end;
writeln(s);
end.
larazaytseva
Отвечу на первый вопрос (всё-таки по правилам сайта вы должны задавать одно задание, иначе просто и вряд ли кто возьмётся, и решать будут долго, и ответ займёт кучу места).

Расставим в порядке убывания количества информации:
1) терабайт    -это 1024 гигабайта (2^40 байт)
2) гигабайт    -это 1024 мегабайта (2^30 байт)
3) мегабайт   -это 1024 килобайта (2^20 байт)
4) килобайт    -это 1024 байта (2^10 байт)
5) байт           -состоит из 8 бит (8 двоичных разрядов)
6) бит и двоичный разряд   -в них равное количество информации (это минимальное количество информации; бит может находится в двух различных состояниях, обозначаемых как ноль и единица)
pnat1235
1. Внутреннюю — оперативную и внеш¬нюю — долговременную
2. Управление устройствами и задачами
3. Красный, зеленый, синий
4. Целые числа в памяти компьюте¬ра это:
Дискретное и конечное множество
5. Контроллер
6. Передача данных, передача адресов

7. D

8. Прикладные программы общего назначения и специализированные программы
9. Главная формула информатики?
2i = N
16i = N
2f = Z
2i = M

10. Прикладные программы и системные программы

11. К основным типам устройств оперативной памяти относятся?
Динамическая и статическая память
12. Компьютер
13. Какой универсальный звуко¬вой формат файлов используется для сохранения звука без потерь?
WAV

14. Множество целых чисел в компьютере дискретно, конечно, ограничено

15. В памяти компьютера числа хранятся?
В двоичной сис¬теме счисления

16. Архитектура персонального компьютера это?
Общие принципы построения компьютера

17. Как называется инструмент для работы профессиональных программистов?
Многопользовательские и многозадачные системы программирования

18. Какой термин считается правильным о представлении о множестве целых чисел в математике?
Множество целых чисел дискретно, бесконечно, неограниченно

19. Текстовая информация уже дискретна и состоит из?
Отдельных знаков

20. Какую графику применяют при разработке электронных и полиграфических изданий?
Векторная

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая в последовательности целых чисел определяет сумму чётных чисел, принадлежащих интервалу (15, 190) или сообщает, что таких чисел нет (выводит "net" программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 -- признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму чётных чисел, принадлежащих интервалу (15, 190) или вывести "net", если таких чисел нет. пример работы программы: вход: 5 15 25 48 180 196 0 выход: 228 (48+180) язык паскаль
Ваше имя (никнейм)*
Email*
Комментарий*
▲