natkoff5
?>

Написать программу, для вычисления количества всех трехзначных чисел, которые делятся на 3. написать в программе кумир.

Информатика

Ответы

татьяна1245
Алг Числа
нач
 цел k,i
 k:=0
 нц для i от 100 до 999
  если mod(i,3)=0 то
   k:=k+1
  все
 кц
 вывод "k = ", k
кон
Написать программу, для вычисления количества всех трехзначных чисел, которые делятся на 3. написать
АлександровнаВладимирович1424
алг Трехзначные
нач цел a,i
a:=0;
нц для i от 100 до 999
i:=mod(i,3);
если i=0
то a:=a+1;
все
кц
вывод "Количество 3-хзначных чисел кратных 3-ем - ", a
кон
Татьяна
В Бейсике есть встроенная функция ATN - арктангенс,
поэтому угол можно в градусах посчитать.

DIM a, b, c, cs, cst, ang, PI
INPUT " a = ", a
INPUT " b = ", b
INPUT " c = ", c
PRINT
PI = 3.141593
cs = (b * b + c * c - a * a) / (2 * b * c)
cst = cs
IF cs < 0 THEN cst = SQR(1 - cs * cs)
ang = ATN(SQR(1 - cst * cst) / cst) * 360 / (2 * PI)
IF cs < 0 THEN ang = ang + 90
PRINT "угол A = ",
PRINT USING "###.##"; ang
cs = (a * a + c * c - b * b) / (2 * a * c)
cst = cs
IF cs < 0 THEN cst = SQR(1 - cs * cs)
ang = ATN(SQR(1 - cst * cst) / cst) * 360 / (2 * PI)
IF cs < 0 THEN ang = ang + 90
PRINT "угол B = ",
PRINT USING "###.##"; ang
cs = (a * a + b * b - c * c) / (2 * a * b)
cst = cs
IF cs < 0 THEN cst = SQR(1 - cs * cs)
ang = ATN(SQR(1 - cst * cst) / cst) * 360 / (2 * PI)
IF cs < 0 THEN ang = ang + 90
PRINT "угол C = ",
PRINT USING "###.##"; ang
PRINT "Выход - любая клавиша ... "
DO
LOOP WHILE INKEY$ = ""
gameover98
Немного теории.
Для того, чтобы избежать переполнения разрядной сетки, значение квадрата натурального числа не должно превышать максимального числа, представимого выбранным типом данных.
В языке Паскаль числа типа longint записываются в четырех байтах в дополнительном коде, т.е. максимальное значение числа не может превышать 2³¹-1. Тогда максимальное натуральное число, квадрат которого мы можем вычислить, равно целой части от величины:
\displaystyle \lim:= \sqrt{2^{31}-1} \approx 2^{31/2}=2^{15.5}= e^{15.5\cdot ln(2)} 

//PascalABC.Net 3.0, сборка 1066
var
  s:string;
  i,n,lim,l:longint;
begin
  lim:=Trunc(exp(15.5*ln(2)));
  Write('Введите номер позиции: '); Read(n);
  i:=0; l:=0;
  while (l<n) and (i<=lim) do begin
    Inc(i); Str(i*i,s); l:=l+Length(s);
  end;
  if i<=lim then Writeln('Искомая цифра- ',s[Length(s)-l+n])
  else Writeln('Решения в типе данных longint невозможно')
end.

Тестовое решение:
Введите номер позиции: 4
Искомая цифра- 1

Введите номер позиции: 33
Искомая цифра- 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, для вычисления количества всех трехзначных чисел, которые делятся на 3. написать в программе кумир.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevsyukov1697
lenalevmax7937
koam20167459
Станиславович1830
annabanova9
eisakov86
yuklimochkina3
dimoni86
aidapiltoyan43
Galiaahmatova4447
lebedevevgen
nataliagorki476
yana799707
bieku68
Alisa1639