mamaevmvv3
?>

9.к какому типу относится оператор text? a. символьный в. целый с. логический d. текстовый 10.к какому типу относится оператор array? a. текстовый b. файловый c. массивный d. сборный 11.к какому типу относится оператор record? a. файловый b. сборные c. массивные d. сложные комбинированные 12.к какому типу относится оператор set? a. массивный b. текстовый c. файловый d. множественные 13.к какому типу относится оператор file? a. типовые b. текстовые c. файловые d. массивный 14.к какому типу относится оператор char? a. символический b. логический c. целый d. действительный

Информатика

Ответы

Александр
9-d
10-c
11-d
12-d
13-c
14-a
Akopovich802
1)Составьте программу, которая находит большее из двух введенных с
клавиатуры чисел a, b и выводит его на экран. Числа 7 и 9
var a,b : integer;
begin
 write('Enter a: ');
 read(a);
 write('Enter b: ');
 read(b);
 if a>b then writeln(a)
 else writeln(b);
end.
2) Составьте программу, которая находит меньшее из трёх введенных
чисел a, b, c и выводит его на экран. Числа 10, 4 и 9
var a,b,c : integer;
begin
 write('Enter a: ');
 read(a);
 write('Enter b: ');
 read(b);
 write('Enter c: ');
 read(c);
 if (a<b) and (b<c)  then writeln(a);
  if (b<c) and (c<a) then writeln(b)
  else writeln(c);
end.
3) Составьте программу определяющую, является ли введенное с
клавиатуры целое число кратным 3.
var a: integer;
begin
 write('Enter a: ');
 read(a);
 if (a mod 3) = 0 then writeln('Кратно')
 else writeln('Не кратно');
end.
Vasilii1891
Задача №1
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
Var n, i: integer; 
Begin                   
writeln ('Введите число');
readln(n);                                    
writeln('Делители числа:');  
for i := 1 to n div 2 do     
  if (n mod i) = 0 then begin 
    write(i,'  ');
  end;         
End.       

Задача №2 (алгоритм не очень шустрый, но работает и понятный)
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
var
  a, b, x, y, nod: integer;

begin
  writeln('Введите a,b');
  readln(a, b);
  x := a;y := b;
  while x <> y do
    if x > y
      then x := x - y
    else y := y - x;
  nod := x;
  writeln('NOD(', a, ',', b, ')=', nod);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

9.к какому типу относится оператор text? a. символьный в. целый с. логический d. текстовый 10.к какому типу относится оператор array? a. текстовый b. файловый c. массивный d. сборный 11.к какому типу относится оператор record? a. файловый b. сборные c. массивные d. сложные комбинированные 12.к какому типу относится оператор set? a. массивный b. текстовый c. файловый d. множественные 13.к какому типу относится оператор file? a. типовые b. текстовые c. файловые d. массивный 14.к какому типу относится оператор char? a. символический b. логический c. целый d. действительный
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilma20168
Nikolai_oksana
Igorevich1512
sychevao19975
eidevyatkina
АнжелаВасильевич
pryvalovo48
ЮрьевичКарпова1564
Chikichev456
Taurus59707
YeVgenii
volna22051964
Yulechkaakulova1993
Avdeeva Inga1505
Татьяна1045