ivanjeka87
?>

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 5% предоставляется, если сумма покупки больше 2500 руб., в 10% - если сумма больше 3500 руб. в c++

Информатика

Ответы

rsd737
#include < iostream >
using namespace std;
int main () {
int a;
cout << "Введите сумму покупки: " << endl;
cin >> a;
if (a >= 2500){
cout << "Итог: ";
if (a >= 2500 && a <= 3500)
cout << a*(1 - 0.05) << endl;
else if (a > 3500)
cout << a*(1 - 0.1) << endl;
}
else
cout << "Без скидки. Итог: " << a << endl;
}
grafffmc

Відповідь:

from random import randint as randit

num = int(input("Введіть число: "))

lst = []

for elem in range(5):

   lst.append( randit(1, 50) )

   sumlist = sum(lst)

print("Сума чисел у масиві", sumlist)

print("Масив", lst)

if num > sumlist:

   print("Число", str(num), "більше за суму чисел у масиві")

elif num < sumlist:

   print("Число", str(num), "меньше за суму чисел у масиві")

elif num != sumlist:

   print("Число", str(num), "не дорівнює сумі чисел у масиві")

elif num == sumlist:

   print("Число", str(num), "дорівнює сумі чисел у масиві")

Пояснення:

Зияева57

#include <iostream>

#include <string>

#define N 5

using namespace std;

int count_flat = 0;

struct Flat {

int n_rooms;

int square;

int floor;

string address;

double price;

void PrintInfo() {

 cout << "\nКоличество комнат: " << n_rooms << "\nПлощадь " << square << "\nЭтаж:" << floor << "\nАдрес " << address << "\nЦена: " << price;

}

void InputInfo() {

 cout << "Количество комнат: ";

 cin >> n_rooms;

 cout << "Площадь: ";

 cin >> square;

 cout << "Этаж: ";

 cin >> floor;

 cout << "Адрес: ";

 getline(cin, address);

 cout << "Цена: ";

 cin >> price;

}

void PrintChecksInfo(int number) {

 

 if (number >= price) {

  count_flat++;

  PrintInfo();

 }

}

};

signed main() {

setlocale(LC_ALL, "Rus");

int choice;

Flat mas[N];

for (int i = 0; i < N; i++)

 mas[i].InputInfo();

cout << "Введите стоимость: ";

cin >> choice;

for (int i = 0; i < N; i++) {

 mas[i].PrintChecksInfo(choice);

}

if (count_flat <= 0)

 cout << "Таких квартир нет!";

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 5% предоставляется, если сумма покупки больше 2500 руб., в 10% - если сумма больше 3500 руб. в c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yulyaderesh
Наталья Юрьевич1228
aamer9992680
Anastasiya Yevseeva948
чухловина209
Татьяна
Dmitriy793
fmba18
muzeynizhn
slastena69678
lobutev
Sadovskaya425
polina25258
marinakovyakhova
ooottdi