saltikovaK.S.1482
?>

Паскаль. напишите программу, которая запрашивает ввод массива b и выводит на экран его элементы в табличной форме: 1 2 3 4 2 3 4 5 3 4 5 6 выведите на экран среднее арифметическое элементов массива b.

Информатика

Ответы

irina25095462
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  var b:=ReadMatrInteger(m,n);
  b.Println(4); Writeln(4*b.ColCount*'-');
  Writeln('Ср.арифм. равно ',b.ElementsByRow.Average)
end.

Пример
Количество строк и столбцов в массиве: 3 4
1 2 3 4
2 3 4 5
3 4 5 6
   1   2   3   4
   2   3   4   5
   3   4   5   6

Ср.арифм. равно 3.5
Donleksa2016

Информационные технологии-это процессы, методы поиска, сбора, хранения, обработки, предоставления

Термин «информационные технологии» в его современном смысле впервые появился в статье 1958 года, опубликованной в Harvard Business Review; авторы Гарольд Дж. Ливитт и Томас Л. Уислер прокомментировали, что «у новой технологии еще нет единого установленного имени. Мы будем называть это информационными технологиями (ИТ)»[источник не указан 314 дней]. Их определение состоит из трех категорий: методов обработки, применения статистических и математических методов для принятия решений и моделирования мышления более высокого порядка с компьютерных программ.

Информационные технологии начали активно развиваться с 1960-х годов, вместе с появлением и развитием первых информационных систем (ИС).

Компания IBM выпустила первый жёсткий диск в 1956 году, в качестве компонента компьютерной системы 305 RAMAC. Большинство цифровых данных сегодня по-прежнему сохраняется магнитно на жёстких дисках или оптически на носителях, таких как компакт-диски. До 2002 большинство информации хранилось на аналоговых устройствах, но в том году цифровая ёмкость превысила аналоговое устройство впервые. По состоянию на 2007, почти 94 % данных, хранящихся во всем мире, сохранилась в цифровом виде: 52 % на жёстких дисках, 28 % на оптических устройств и 11 % на цифровой магнитной ленте. Было подсчитано, что в мире ёмкость для хранения информации на электронных устройствах выросла с менее чем 3 эксабайт в 1986 году до 295 экзабайт в 2007 году, увеличиваясь вдвое примерно каждые 3 года.

Galina3241

Современный период развития общества характеризуется сильным влиянием на него компьютерных технологий, которые проникают во все сферы человеческой деятельности, обеспечивают распространение информационных потоков в обществе, образуя глобальное информационное пространство. Неотъемлемой и важной частью этих процессов является компьютеризация образования. В настоящее время в России идет становление новой системы образования, ориентированного на вхождение в мировое информационно-образовательное пространство. Этот процесс сопровождается существенными изменениями в педагогической теории и практике учебно-воспитательного процесса, связанными с внесением корректив в содержание технологий обучения, которые должны быть адекватны современным техническим возможностям, и гармоничному вхождению ребенка в информационное общество. Компьютерные технологии призваны стать не дополнительным «довеском» в обучении, а неотъемлемой частью целостного образовательного процесса, значительно повышающей его эффективность.

За последние 5 лет число детей, умеющих пользоваться компьютером, увеличилось примерно в 10 раз. Как отмечает большинство исследователей, эти тенденции будут ускоряться независимо от школьного образования. Однако, как выявлено во многих исследованиях, дети знакомы в основном с игровыми компьютерными программами, используют компьютерную технику для развлечении. При этом познавательные, в частности образовательные, мотивы работы с компьютером стоят примерно на двадцатом месте. Таким образом, для решения познавательных и учебных задач компьютер используется недостаточно.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. напишите программу, которая запрашивает ввод массива b и выводит на экран его элементы в табличной форме: 1 2 3 4 2 3 4 5 3 4 5 6 выведите на экран среднее арифметическое элементов массива b.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Щуплова Александр
anadtacia03108988
rimmaskis
Максим
Vitalik6928
Dmitrievich1871
yaart-klementiev29
Новицкий1107
Ананян Иван1281
Mexx9050
tarigor
Антонович937
boykoz9
Sacharov84
Bni1504