smakejkina
?>

Составьте программу, которая будет определять положительное или отрицательное введённое пользователем число. (программа турбо паскаль)

Информатика

Ответы

orb-barmanager

program w7w7;

var a: real;

begin

readln (a);

if a< 0 then writeln ('otritsatelnoe chislo');

if a> 0 then  writeln ('pologitelnoe chislo');

end.

ivanovmk1977

Графические редакторы - пакеты, предназначенные для обработки графической информации. Они делятся на ППП обработки растровой графики и изображений и векторной графики. Растровые графические редакторы предназначены для работы с фотографиями и включают в себя набор средств по кодированию фотоизображения в цифровую форму.

С растровых графических редакторов можно обрабатывать фотографии и рисунки, поскольку растровые изображения обеспечивают высокую точность передачи градаций цветов и полутонов. Структура растровых изображений кардинально отличается от векторных. Растровые изображения состоят из отдельных точек - пикселей. Такие изображения обеспечивают максимальную реалистичность, поскольку в цифровую форму переводится каждый мельчайший фрагмент оригинала. Такие изображения сохраняются в файлах гораздо большего объёма, чем векторные, поскольку в них запоминается информация о каждом пикселе изображения. Таким образом, качество растровых изображений зависит от их размера (числа пикселей по горизонтали и вертикали) и количества цветов. Как следствие того, что они состоят из пикселей фиксированного размера, свободное масштабирование без потери качества к ним не применимо. Эта особенность, а также сама структура растровых изображений несколько затрудняет их редактирование и обработку.

Векторные изображения являются оптимальным средством для хранения высокоточных графических объектов (чертежи, схемы и т. д.), для которых имеет значение наличие четких и ясных контуров. Все компоненты векторного изображения описываются математически, а значит - абсолютно точно. Векторные изображения, как правило, строятся вручную, однако в некоторых случаях они могут быть также получены из растровых с программ трассировки. Векторные изображения не в состоянии обеспечить близкую к оригиналу реалистичность, но достоинством векторной графики является то, что файлы, хранящие векторные графические изображения, имеют сравнительно небольшой объем. Важно также, что векторные графические изображения могут быть увеличены или уменьшены без потери качества.

Панели инструментов графических редакторов. Графические редакторы имеют набор инструментов для создания или рисования простейших графических объектов: прямой линии, кривой, прямоугольника, эллипса, многоугольника и т. д. После выбора объекта на панели инструментов его можно нарисовать в любом месте окна редактора. Выделяющие инструменты. В графических редакторах над элементами изображения возможны различные операции: копирование, перемещение, удаление, поворот, изменение размеров и т. д. Чтобы выполнить какую-либо операцию над объектом, его сначала необходимо выделить.

Для выделения объектов в растровом графическом редакторе обычно имеются два инструмента: выделение прямоугольной области и выделение произвольной области. Процедура выделения аналогична процедуре рисования.

Выделение объектов в векторном редакторе осуществляется с инструмента выделение объекта (на панели инструментов изображается стрелкой). Для выделения объекта достаточно выбрать инструмент выделения и щелкнуть по любому объекту на рисунке. Инструменты редактирования рисунка позволяют вносить в рисунок изменения: стирать его части, изменять цвета и т. д. Для стирания изображения в растровых графических редакторах используется инструмент Ластик, который убирает фрагменты изображения (пиксели), при этом размер Ластика можно менять. В векторных редакторах редактирование изображения возможно только путем удаления объектов, входящих в изображение, целиком. Для этого сначала необходимо выделить объект, а затем выполнить операцию Вырезать.

Операцию изменения цвета можно осуществить с меню Палитра, содержащего набор цветов, используемых при создании или рисовании объектов.

Текстовые инструменты позволяют добавлять в рисунок текст и форматировать его. В векторных графических редакторах легко изменять реальные размеры объекта с мыши.

В растровых редакторах инструментом Надпись (буква А на панели инструментов) создаются текстовые области на рисунках. Установив курсор в любом месте текстовой области, можно ввести текст. Форматирование текста производится с панели Атрибуты текста. В векторных редакторах тоже можно создавать текстовые области для ввода и форматирования текста. Кроме того, надписи к рисункам вводятся посредством так называемых выносок различных форм.

Масштабирующие инструменты в растровых графических редакторах дают возможность увеличивать или уменьшать масштаб представления объекта на экране, не влияя при этом на его реальные размеры. Обычно такой инструмент называется Лупа.

Объяснение:

Александр Сергей
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! 1) begin   var (n,m): =readinteger2('количество строк и столбцов в массиве: ');   writeln('*** исходный массив [',n,',',m,'] ***');   var a: =matrrandom(n,m,-99,99);   a.println(4); writeln(4*a.colcount*'-');   var b: =a.rows.select(r-> r.where(t-> t.isodd).lastordefault); b.println; end. пример количество строк и столбцов в массиве: 8 5 *** исходный массив [8,5] ***   -41  36 -99  14  17   -22  12  71 -94 -42   -35 -40  26    2  24   39  17  20  11  84   -53 -18  97  -6    5     2  67 -54  -6  -3   95 -87  90 -13 -37   -81 -21  61 -90 -60 17 71 -35 11 5 -3 -37 61 2) begin   writeln('*** исходный массив ***');   var a: =matrrandom(20,10,2,5);   a.println(2); writeln(2*a.colcount*'-');   writeln('ср. 5-го ученика: ',a.row(4).average) end. пример *** исходный массив ***   2 2 3 3 4 3 4 2 3 2   4 3 2 3 2 4 3 2 5 3   4 2 3 3 4 5 5 2 2 4   5 2 4 2 4 5 4 2 3 3   5 3 3 2 3 4 5 4 4 4   3 2 3 2 3 2 5 2 4 4   4 4 5 5 2 4 5 5 4 2   2 2 5 4 4 2 4 3 2 2   2 2 4 4 2 4 4 4 5 4   2 3 4 4 5 3 3 4 5 4   5 2 5 3 3 2 3 5 3 2   3 4 2 3 4 3 2 3 4 3   2 2 2 2 2 4 4 2 4 2   5 2 3 3 3 5 3 2 2 5   2 4 2 4 3 3 3 2 5 4   3 2 5 4 4 4 5 5 3 5   4 3 2 3 3 2 2 4 2 4   2 5 2 5 2 3 2 4 5 4   3 3 2 2 5 4 3 5 4 4   2 3 5 3 3 5 4 5 2 2 ср. 5-го ученика: 3.7

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая будет определять положительное или отрицательное введённое пользователем число. (программа турбо паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zanthia94
sveremeev816
Ruslan374
art-03857
mantseva
Kashtelyan Tamara847
Valerevna
Yelizaveta555
Petrushin482
Belik-elena20111
Васильева-Александрович
GALINAMTO
zakaz6354
oxy03214428
Бернард pokerman
▲