info292
?>

Вравенстве ** + ***= цифры заменены звездочками. известно, что каждое их трёх чисел является палиндромом. программа должна их найти. (составить программу в pascal abc)

Информатика

Ответы

Klochkov malakhov1974
Если вынуть 98 конфет, то будут конфеты всех 3 видов.
Пусть у нас по n конфет каждого вида.
Тогда может так получиться, что мы вынем 2n конфет, и они будут только 2 видов. И только, вынув (2n+1)-ю конфету, мы получим все три.
2n+1 = 98
2n = 97.
Значит, конфет одного и другого вида по [97/2] = 48,
а конфет третьего вида 49.
Пусть ирисок и леденцов по 48, а шоколадных 49.
Вынув 48 ирисок и 48 леденцов (96 конфет), мы получим 2 вида.
Вынув 48 ирисок и 49 шоколадных (97), мы получим 2 вида.
Вынув 48 леденцов и 49 шоколадных (97), мы получим 2 вида.
И только вынув 98-ую (в 1 случае 97 и 98), мы получим 3 вида.
ответ: всего конфет было 48 + 48 + 49 = 145.
КалюкМарасанов1026

dim a, b, t, m, r as integer

a = -20: b = 20

m = a: r = f(a)

for t = a to b

    if f(t) < r then

        m = t

        r = f(t)

    end if

next t

print r

 

function f(x)

    f : = 4*(x-5)*(x+3)

end function

var a,b,t,m,r : integer;

    function f(x: integer): integer;

    begin

        f : = 4*(x-5)*(x+3);

    end;

begin

    a : = -20; b : = 20;

    m : = a; r : = f(a);

    for t : = a to b do begin

        if (f(t)< r) then begin

            m : = t;

            r : = f(t);

        end;

    end;

write(r);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вравенстве ** + ***= цифры заменены звездочками. известно, что каждое их трёх чисел является палиндромом. программа должна их найти. (составить программу в pascal abc)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pk199888
tyrnaus
vasilevich-F
ibzaira
Skvik71
Vrpeshka
MISAKOVNA49
Strelkov-Roman1263
kuharhuks
shabunina17
e-liza-k
dkvsadovoe
ksyrika
ivanjeka87
tanyatanyat