Nikolaevich-Svetlana388
?>

Напишите программу вычисления a и b и сравните их, если x=10: a: =(x+6)*scr(x)-sqrt(x-1); b: =abs(x-15)*sqr(x+1)/242; . 99

Информатика

Ответы

syana80
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var x:=10;
  var a:=(x+6)*Sqr(x)-Sqrt(x-1);
  var b:=Abs(x-15)*Sqr(x+1)/242;
  Writeln('a=',a,', b=',b,', a-b=',a-b)
end.

Результат
a=1597, b=2.5, a-b=1594.5
МуратМарина1140
Код на руби

x = 10
a = (x+6)*x*x-(x-1.0)**0.5
b = (x-15).abs*(x+1)**2.0/242
p [a,b,a-b]

Вывод
[1597.0, 2.5, 1594.5]
Sergei-Gradus199

Разберем оператор по шагам. Обозначим Т - промежуточный результат операции.y:= round(y*(7 div 4) mod 7/3)/y - trunc(0.724);1) T:= 7 div 4 ⇒ T:=1, тип T целочисленный.2) T:=y*T, тип Т определяется типом y.3) T:=T mod 7, в операции mod операнды могут быть только целочисленными, следовательно, тип у в 2) может быть только целочисленным, иначе мы получим на данном шаге ошибку. Результат операции - Т целочисленного типа.4) T:=T/3; T - вещественного типа.5) T;=round(T); T - целочисленного типа.6) T:=T/y, T - вещественного типа.7) Trunc(0.724)
вернет 0 целочисленного типа.8) Т:=T-0 не изменит значения и типа Т: Т по-прежнему остается вещественным.9) y:=T; для корректного присваивания y должен иметь вещественный тип, но это, как указано в 3), вызовет ошибку при выполнении 2).Итог: оператор недопустим и будет отмечен ошибочным при компиляции


Nasteona1994
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace 1
{
class Program
{
static void Main(string[] args)
{
bool Mistake = false;
int N = 0;

do
{
Console.Write("Введите количество слагаемых: ");

try
{
N = Convert.ToInt32(Console.ReadLine());
Mistake = false;

}

catch (FormatException)
{
Mistake = true;

Console.Clear();
Console.WriteLine("Неверный формат ввода! Повторите попытку!");
Console.WriteLine();
}
}

while (Mistake == true);

Sum(N);
}

static void Sum(int N)
{
double[] Elements = new double[N];
double Result = 0;

for (int i = 0; i < N; i++)
{
Console.WriteLine();
Console.Write("Введите " + (i + 1) + " число: ");

try
{
Elements[i] = Convert.ToDouble(Console.ReadLine());
}

catch (FormatException)
{
Console.WriteLine("Неверный формат ввода!");
}
}

for (int j = 0; j < N; j++)
{
Result += Elements[j];
}

Console.WriteLine();
Console.Write("Сумма = " + Result);
Console.ReadKey();
}
}
}
Напиши программу, которая выводит сумму n чисел, введенных пользователем. число n должно так же опре
Напиши программу, которая выводит сумму n чисел, введенных пользователем. число n должно так же опре
Напиши программу, которая выводит сумму n чисел, введенных пользователем. число n должно так же опре

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу вычисления a и b и сравните их, если x=10: a: =(x+6)*scr(x)-sqrt(x-1); b: =abs(x-15)*sqr(x+1)/242; . 99
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uchpapt
dariamay1996
Soliyabronzoni
pelagia-kola2658
Виктор Попова
Semenovt
Stepanovich_Makarov
annasv8
shymilin19951783
ЕлизаветаВладимирович
themolodoy
Vladimir
vadimkayunusov
Vos-sv
chumakanna17
▲