ganorussia
?>

Написать программу на языке паскаль, которая запрашивает у пользователя 10 чисел и заполняет полученными от пользователя числами массив. далее программа должна вывести на экран индексы и значения тех элементов массива, в которых содержатся положительные числа. например: пользователь ввел числа 1, -2, -3, 4, 5, -6, 8, 100, -200, 45 программа должна вывести на экран: 1 - 1 4 - 4 5 - 5 7 - 8 8 - 100 10 – 45 не в коем случае не используй const, count и т.д. обыкновенным по возможности.

Информатика

Ответы

Назаров588
Var 
  a: array[1..10] of integer;
  i: integer;
begin
  for i := 1 to 10 do 
    read(a[i]);
  for i := 1 to 10 do
    if a[i] > 0 then
      writeln(i, ' - ', a[i])
end.
Написать программу на языке паскаль, которая запрашивает у пользователя 10 чисел и заполняет получен
irina25095462
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

function IsPrime(m:integer):=(Range(2,Round(sqrt(m))).All(x->m mod x<>0));

begin
  var n:=ReadInteger('n=');
  Range(1,n).Where(i->IsPrime(i)).Println
end.

Пример
n= 318
1 2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97 101 103 107 109 113 127 131 137 139 149 151 157 163 167 173 179 181 191 193 197 199 211 223 227 229 233 239 241 251 257 263 269 271 277 281 283 293 307 311 313 317

// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

function NOD(m,n:integer):integer;
begin
  while n>0 do (m,n):=(n,m mod n);
  Result:=m
end;

begin
  var a,b:integer;
  Write('Введите пару натуральных чисел:'); Read(a,b);
  Writeln('НОД=',NOD(a,b))
end.

Пример
Введите пару натуральных чисел:7955 5661
НОД=37

Синформатикой, . 1. напишите программу, которая выводит на экран все простые числа в диапазоне от 1
YuRII1236
1.
program pr1;
uses crt;
var n,k,i,t:integer;
begin
clrscr;
write('Введите целое число n=');
readln (n);
for i:=2 to n do begin
t:=0;
for k:=2 to n do
if i mod k=0 then t:=t+1;
if t=1 then write(i:3);
end;
readln;
end.

2.

Program pr2;
Var a, b: Integer;

Function NOD(a, b: Integer): Integer;
Var tmp, r: Integer;
Begin
If b > a Then
Begin
tmp := a;
a := b;
b := tmp;
End;
tmp := a;
While tmp > 0 Do
Begin
Result := tmp;
tmp := tmp - b;
End;
End;

Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
Write('НОД: ', NOD(a, b));
ReadLn;
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке паскаль, которая запрашивает у пользователя 10 чисел и заполняет полученными от пользователя числами массив. далее программа должна вывести на экран индексы и значения тех элементов массива, в которых содержатся положительные числа. например: пользователь ввел числа 1, -2, -3, 4, 5, -6, 8, 100, -200, 45 программа должна вывести на экран: 1 - 1 4 - 4 5 - 5 7 - 8 8 - 100 10 – 45 не в коем случае не используй const, count и т.д. обыкновенным по возможности.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aksmobile
kzhgutova
kapitan19
ooost-2022
zakupki
MikhailSvetlana
Borisovich-Volobueva1803
misstimarina2016
shakhnina90
airon-082054
alfaduk24908
postbox
turovskaya69
polikarpov-70
eshabunina