1
Задание 5 № 10383
У исполнителя Альфа две команды, которым присвоены номера:
1. прибавь 1;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 6 в число 82. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10384
У исполнителя Альфа две команды, которым присвоены номера:
1. прибавь 1;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Альфа увеличивает число на экране на 1, а выполняя вторую, умножает это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 11211 переводит число 3 в число 62. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10385
У исполнителя Бета две команды, которым присвоены номера:
1. прибавь 2;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 12111 переводит число 7 в число 51. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10386
У исполнителя Бета две команды, которым присвоены номера:
1. прибавь 2;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Бета увеличивает число на экране на 2, а выполняя вторую, умножает это число на b. Программа для исполнителя Бета — это последовательность номеров команд. Известно, что программа 11121 переводит число 4 в число 72. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10387
У исполнителя Гамма две команды, которым присвоены номера:
1. прибавь 3;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11211 переводит число 1 в число 97. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10388
У исполнителя Гамма две команды, которым присвоены номера:
1. прибавь 3;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Гамма увеличивает число на экране на 3, а выполняя вторую, умножает это число на b. Программа для исполнителя Гамма — это последовательность номеров команд. Известно, что программа 11121 переводит число 3 в число 75. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10389
У исполнителя Омега две команды, которым присвоены номера:
1. прибавь 4;
2. умножь на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Омега увеличивает число на экране на 4, а выполняя вторую, умножает это число на b. Программа для исполнителя Омега — это последовательность номеров команд. Известно, что программа 12111 переводит число 9 в число 77. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10390
У исполнителя Сигма две команды, которым присвоены номера:
1. прибавь 1;
2. раздели на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 63 в число 11. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10391
У исполнителя Сигма две команды, которым присвоены номера:
1. прибавь 1;
2. раздели на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Сигма увеличивает число на экране на 1, а выполняя вторую, делит это число на b. Программа для исполнителя Сигма — это последовательность номеров команд. Известно, что программа 12111 переводит число 50 в число 20. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Задание 5 № 10392
У исполнителя Альфа две команды, которым присвоены номера:
1. прибавь 2;
2. раздели на b
(b — неизвестное натуральное число; b ≥ 2).
Выполняя первую из них, Альфа увеличивает число на экране на 2, а выполняя вторую, делит это число на b. Программа для исполнителя Альфа — это последовательность номеров команд. Известно, что программа 12111 переводит число 47 в число 13. Определите значение b.
Решение · Поделиться · Сообщить об ошибке Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
1)var a,b:array[1..101] of longint;i,n,k:integer;beginfor i:=1 to 100 do a[i]:=random(128000)-64000;for i:=1 to 100 do beginif a[i]>0 then begin b[i]:=a[i];inc(k);end;if a[i]<0 then begin while a[i]>0 doa[i]:=a[i+1];end;end;for i:=1 to k doif b[i]<>0 thenwriteln(b[i]);end.
2)var a:array[1..50] of integer;i,k:integer;beginfor i:=1 to 50 do a[i]:=random(64000)+1;//for i:=1 to 50 do if a[i] mod 3 =0 then writeln(a[i]); если хотите посмотреть на эти числа убрать //for i:=1 to 50 do if a[i] mod 3 =0 then k:=k+a[i];write(k);end.