Rik200081490
?>

Составьте программу к : вывести 20 первых чисел так чтобы каждое последующее было на меньше предыдущего . первое число 25

Информатика

Ответы

Vasilevich
Var i:integer;
begin
for i:=25 downto 6 do writeln(i)
end.
Демидова Красноцветов
1. Частота дискретизации определяет количество отсчетов (т.е. измерений) сигнала, которое делается за одну секунду. Частота 8 кГц = 8000 Гц говорит нам о том, что таких отсчетов делается в секунду 8000.
2. Глубина кодирования сообщает о том, на сколько уровней громкости делится каждый звуковой сигнал. 16 бит позволяют иметь два в шестнадцатой степени уровней.
3. Тогда для сохранения информации нам потребуется 8000 х 16 = 128 000 бит.
4. Файл, с длительностью звучания в одну минуту потребует для сохранения данных в 60 раз больше времени (в минуте 60 секунд) или 128 000 х 60 бит.
5. В одном килобайте 1024 байт, а в одном байте 8 бит. Поэтому найденный объем файла надо разделить на 1024 х 8 = 8192. Получим 128000х60/8192=937.5 Кбайт
6. Поскольку файл монофонический, то используется один канал звука и ответом будет вычисленное значение 937.5 Кбайт. В противном случае найденное значение надо умножить на число звуковых каналов.
sergeylive
1.var
   max,min,i:integer;
   b:real;
   a:array[1..9]of integer;
begin
for i:=1 to 9 do
  begin
  while (a[i]<1) or (a[i]>6) do
    begin
    write(i,' оценка: ');
    readln(a[i]);
    end;
  if i=1 then
    begin
    max:=a[1];
    min:=a[1];
    end;
  if a[i]>max then max:=a[i];
  if a[i]<min then min:=a[i];
  b:=b+a[i];
  end;
b:=(b-min-max)/7;
writeln('Зачетная оценка: ',b);
end. 

2. #include <stdafx.h> 
#include <stdio.h> 
#include <math.h> 
#include <stdlib.h> //for rand; 
int main()
 { 
int i, n,M[1]; 
 printf("Vvedit N:");
  scanf("%d",&n); 
for (i = 0; i < n; i++) 
 { 
  M[i] = rand()%10; 
    }
for (i = 0; i < n; i++) 
 { 
     printf("Array[%d] = %d\n", i, M[i]);
  } 
          scanf("%d"); 
return 0; 
}

3. var

a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадковых чисел');
min:=a[0];
for i:=1 to 9 do
if a[i]<min then min:=a[i];
writeln(min, ' - минимальне число.');

end. 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу к : вывести 20 первых чисел так чтобы каждое последующее было на меньше предыдущего . первое число 25
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Look7moscow
Valentina
Anton661
Bi-1704
Avshirokova51
zakup-r51
gsktae7
zabrodin
struev2003260
Морозов
Look7moscow
German
konstantin0112
annademidova-74
brendacepedam