hellomaxim
?>

Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.

Информатика

Ответы

ЕкатеринаРустам
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:integer;
  var (ke,ko):=(0,0);
  for var i:=0 to 9 do begin
    Write('Введите число ',i+1,': '); Read(a);
    if a.IsEven then ke+=1 else ko+=1
    end;
  Writeln('Нечетных чисел ',ko,', четных ',ke)
end.

Пример
Введите число 1: 45
Введите число 2: -25
Введите число 3: 8
Введите число 4: 0
Введите число 5: 16
Введите число 6: 37
Введите число 7: 111
Введите число 8: -5345
Введите число 9: 23
Введите число 10: 15
Нечетных чисел 7, четных 3
lebedev815
Var q,w,e,r,t,y,u,i,o,p,l,s,a: Integer;
begin
writeln('Введите 10 целых чисел');
readln(q,w,e,r,t,y,u,i,o,p);
s:=0;
a:=0;
for l:=0 to 9 do
begin
if l=0 then if q mod 2=0 then s:=s+1 else a:=a+1;
if l=1 then if w mod 2=0 then s:=s+1 else a:=a+1;
if l=2 then if e mod 2=0 then s:=s+1 else a:=a+1;
if l=3 then if r mod 2=0 then s:=s+1 else a:=a+1;
if l=4 then if t mod 2=0 then s:=s+1 else a:=a+1;
if l=5 then if y mod 2=0 then s:=s+1 else a:=a+1;
if l=6 then if u mod 2=0 then s:=s+1 else a:=a+1;
if l=7 then if i mod 2=0 then s:=s+1 else a:=a+1;
if l=8 then if o mod 2=0 then s:=s+1 else a:=a+1;
if l=9 then if p mod 2=0 then s:=s+1 else a:=a+1;
end;
writeln('Чётных: ',s);
writeln('Нечётных: ',a);
end.
atupicyn754

Проект: Руховий контроль за до клавіш стрілок і миші

Мета проекту:

Створити програму, яка дозволяє виконавцю рухатися вправо або вліво, відповідно до натискання клавіш стрілок, але лише після доторкання мишею.

Необхідні матеріали:

   Комп'ютер з клавіатурою та мишею

   Розробницьке середовище або текстовий редактор для написання програми (наприклад, Python)

Кроки реалізації проекту:

   Ініціалізація:

       Створити новий проект в обраному розробницькому середовищі або відкрити текстовий редактор.

       Налаштувати програму для роботи з клавіатурою та мишею.

   Очікування на дотик миші:

       Створити функцію-перевірку, яка буде перевіряти, чи доторкнулася миша.

       Програма повинна зупинятися та очікувати доторкання миші.

   Рух вправо та вліво:

       Після доторкання миші, створити цикл, який буде перевіряти натискання клавіш стрілок.

       Якщо натиснута клавіша стрілка вправо, виконавець повинен рухатися вправо.

       Якщо натиснута клавіша стрілка вліво, виконавець повинен рухатися вліво.

       Цей цикл має тривати, поки миша не буде знову доторкнута.

   Завершення програми:

       Після доторкання миші, програма має завершити свою роботу.

   Тестування:

       Запустити програму та перевірити, чи працює вона згідно з очікуваннями.

       Натискати клавіші стрілок та ігати за рухом виконавця тільки після доторкання миші.

Цей проект дозволить виконавцю рухатися вправо або вліво лише після доторкання миші, що стимулює використання обидвох елементів управління (клавіатура та миша).

BorgovichOA

Користування мобільним телефоном вимагає деяких правил і етикету. Ось декілька загальних правил, які слід дотримуватися:

Объяснение:

1) Використовуйте телефон у відповідних ситуаціях: уникайте розмов по телефону під час важливих зустрічей, в кінотеатрах, у церкві або в інших місцях, де може бути потрібна тиша або спокій.

2) Будьте уважні до оточуючих: не гучно розмовляйте або не включайте гучну музику в общественных місцях. Враховуйте потреби і комфортність інших людей, особливо в общественном транспорті, ресторанах або бібліотеках.

3) Використовуйте гучність та звукові ефекти обережно: якщо ви слухаєте музику або дивитесь відео в громких гучностях, переконайтеся, що це не завдає незручності оточуючим. На публіці краще використовувати навушники або зменшити гучність, щоб не порушувати спокій інших.

4) Заборонені місця: дотримуйтеся правил, пов'язаних з користуванням мобільним телефоном в літаках, госпіталях, поблизу медичного обладнання та в будь-яких інших місцях, де використання мобільних телефонів може створювати небезпеку або перешкоджати роботі пристроїв.

5) Будьте обережні під час водіння: водіння автомобіля або управління будь-яким транспортним засобом вимагає повної уваги. Не використовуйте мобільний телефон під час руху, якщо це не дозволено спеціальними пристроями "гарнітура" або "hands-free".

6) Заборона

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая последовательно запросит 10 целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

superniki87
luza5
Olia72
imosal
cristiansirbu9974
emartynova25
andrew55588201824
mez-omts-d5
secretar62
tefdst
Valentina
orb-barmanager
Nefedova1432
denblacky
tkozina
▲